Ein Sicherheitsserver funktioniert womöglich nicht, wenn keine erfolgreiche Kopplung mit einer Verbindungsserver-Instanz erfolgte.
Problem
Es können die folgenden Sicherheitsserverprobleme auftreten, wenn ein Sicherheitsserver keine Kopplung mit dem Verbindungsserver herstellen konnte:
- Wenn Sie versuchen, den Sicherheitsserver ein zweites Mal zu installieren, kann sich der Sicherheitsserver nicht mit dem Verbindungsserver verbinden.
- Horizon Client kann sich nicht mit Horizon 7 verbinden. Die folgende Fehlermeldung wird angezeigt: Die Authentifizierung von View-Verbindungsserver ist fehlgeschlagen. Für die Ermöglichung einer sicheren Verbindung zu einem Desktop ist kein Gateway verfügbar. Wenden Sie sich an Ihren Netzwerkadministrator.
- Der Sicherheitsserver wird im Horizon Administrator-Dashboard als Ausgefallen angezeigt.
Ursache
Dieses Problem kann auftreten, wenn Sie begonnen haben, einen Sicherheitsserver zu installieren, und der Versuch absichtlich oder unabsichtlich abgebrochen wurde, nachdem Sie ein Kennwort für die Kopplung mit dem Sicherheitsserver eingegeben haben.
Lösung
Wenn Sie beabsichtigen, den Sicherheitsserver in Ihrer Horizon 7-Umgebung zu behalten, führen Sie folgende Schritte aus:
- Wählen Sie in Horizon Administrator aus.
- Wählen Sie auf der Registerkarte Sicherheitsserver einen Sicherheitsserver aus, wählen Sie Auf Aktualisierung oder Neuinstallation vorbereiten aus dem Dropdown-Menü Weitere Befehle aus und klicken Sie auf OK.
- Wählen Sie auf der Registerkarte Verbindungsserver die Verbindungsserver-Instanz aus, die Sie mit dem Sicherheitsserver koppeln möchten, wählen Sie Kennwort für die Kombination des Sicherheitsservers angeben aus dem Dropdown-Menü Weitere Befehle aus, geben Sie das Kennwort ein und klicken Sie auf OK.
- Installieren Sie den Sicherheitsserver erneut.
Wenn Sie vorhaben, den Sicherheitsservereintrag aus Ihrer Horizon 7-Umgebung zu entfernen, führen Sie den Befehl vdmadmin -S aus.
Beispiel: vdmadmin -S -r -s security_server_name