Ein Sicherheitsserver oder eine Verbindungsserver-Instanz, die für sichere Horizon Client-Verbindungen verwendet wird, kann in View Administrator rot angezeigt werden, wenn eine Zertifikatsperrüberprüfung beim TLS-Zertifikat des Servers nicht durchgeführt werden kann.

Problem

Ein Sicherheitsserver- oder Verbindungsserver-Symbol ist im Horizon Administrator-Dashboard rot. Mit dem Status der Horizon 7-Server wird folgende Meldung angezeigt: Das Serverzertifikat kann nicht geprüft werden.

Ursache

Die Zertifikatsperrüberprüfung kann fehlschlagen, wenn Ihre Organisation für den Internetzugriff einen Proxy-Server verwendet oder wenn eine Verbindungsserver-Instanz die Server, die die Sperrüberprüfung durchführen, aufgrund von Firewalls oder anderen Kontrollen nicht erreichen kann.

Eine Verbindungsserver-Instanz führt eine Zertifikatsperrüberprüfung für ihre eigenen Zertifikate und für die Zertifikate auf dem Sicherheitsserver durch, mit dem der Verbindungsserver kombiniert ist. Der VMware Horizon View Connection Server-Dienst wird standardmäßig mit dem Konto LocalSystem gestartet. Wenn sie unter LocalSystem ausgeführt wird, kann eine Verbindungsserver-Instanz die Proxy-Einstellungen, die im Internet Explorer konfiguriert sind, nicht für den Zugriff auf die CRL DP URL oder den OCSP-Antwortdienst verwenden, um den Widerrufstatus des Zertifikats zu ermitteln.

Sie können die Microsoft Netshell-Befehle verwenden, um die Proxy-Einstellungen in die Verbindungsserver-Instanz zu importieren, sodass der Server auf die Websites für die Zertifikatsperrüberprüfung im Internet zugreifen kann.

Lösung

  1. Öffnen Sie auf dem Verbindungsserver-Computer ein Befehlszeilenfenster mit der Einstellung Als Administrator ausführen.
    Klicken Sie beispielsweise auf Start, geben Sie cmd ein, klicken Sie mit der rechten Maustaste auf das Symbol cmd.exe und wählen Sie Als Administrator ausführen aus.
  2. Geben Sie netsh ein und drücken Sie die Eingabetaste.
  3. Geben Sie winhttp ein und drücken Sie die Eingabetaste.
  4. Geben Sie show proxy ein und drücken Sie die Eingabetaste.
    Netshell zeigt an, dass der Proxy auf DIREKT-Verbindung einstellt war. Bei dieser Einstellung kann der Verbindungsserver-Computer keine Verbindung zum Internet herstellen, wenn Ihre Organisation einen Proxy verwendet.
  5. Konfigurieren Sie die Proxy-Einstellungen.
    Geben Sie z. B. an der Eingabeaufforderung netsh winhttp> die Zeichenfolge import proxy source=ie ein.
    Die Proxy-Einstellungen werden auf den Verbindungsserver-Computer importiert.
  6. Überprüfen Sie die Proxy-Einstellungen durch Eingabe von show proxy.
  7. Starten Sie den VMware Horizon View Connection Server-Dienst neu.
  8. Überprüfen Sie im Horizon Administrator-Dashboard, dass das Sicherheitsserver- oder Verbindungsserver-Symbol grün ist.