Wenn Probleme mit Zertifikaten auf einem Horizon 7-Server vorliegen, können Sie keine Verbindung mit Horizon Administrator herstellen, oder der Systemzustand des Servers wird rot angezeigt.

Problem

Auf der Verbindungsserver-Instanz, auf der das Problem auftritt, können Sie keine Verbindung mit Horizon Administrator herstellen. Wenn Sie auf einer anderen Verbindungsserver-Instanz im selben Pod eine Verbindung mit Horizon Administrator herstellen, wird der Systemzustand der problematischen Verbindungsserver-Instanz im Dashboard rot angezeigt.

Wenn Sie von der anderen Verbindungsserver-Instanz aus auf die rote Anzeige des Systemzustands klicken, wird SSL-Zertifikat: Ungültig und Status: (leer) angezeigt. Dies weist darauf hin, dass kein gültiges Zertifikat gefunden werden konnte. Die Horizon 7-Protokolldatei enthält einen Eintrag des Typs FEHLER mit folgender Meldung: Keine passenden Zertifikate im Schlüsselspeicher.

Die Horizon 7-Protokolldaten befinden sich in C:\ProgramData\VMware\VDM\logs\log-*.txt auf der Verbindungsserver-Instanz.

Ursache

Wenn ein Zertifikat nicht ordnungsgemäß auf einem Horizon 7-Server installiert ist, kann dies einen der folgenden Gründe haben:

  • Das Zertifikat befindet sich nicht im Ordner „Persönlich“ des lokalen Windows-Zertifikatspeichers auf dem Computer.
  • Der Zertifikatspeicher hat keinen privaten Schlüssel für das Zertifikat.
  • Das Zertifikat hat nicht den Anzeigenamen vdm.
  • Das Zertifikat wurde auf Grundlage einer V3-Zertifikatvorlage für Windows Server 2008 oder höher generiert. Horizon 7 kann keinen privaten Schlüssel erkennen, aber wenn Sie den Windows-Zertifikatspeicher mit dem Zertifikat-Snap-In überprüfen, gibt der Speicher an, dass ein privater Schlüssel vorhanden ist.

Lösung