Wenn Sie den View Composer-Dienst mit dem View Composer-Installationsprogramm aktualisieren oder den Befehl SviConfig databaseupgrade ausführen, wird bei diesem Vorgang möglicherweise nicht die View Composer-Datenbank aktualisiert.
Problem
Der Vorgang SviConfig databaseupgrade zeigt den Fehlercode 17 an, oder das View Composer-Installationsprogramm zeigt eine Warnmeldung an.
Datenbank-Upgrade mit Warnungen abgeschlossen
Ursache
Die Datenbank-Upgrade-Software kontaktiert vCenter Server, um zusätzliche Daten über Desktops abzurufen. Das Datenbank-Upgrade kann fehlschlagen, wenn die Desktops nicht verfügbar sind, der ESXi-Host nicht ausgeführt wird oder vCenter Server nicht zur Verfügung steht.
Lösung
- Weitere Informationen hierzu finden Sie in der View Composer-Protokolldatei SviConfig.
Standardmäßig befindet sich diese Datei unter
C:\Benutzer\All Users\VMware\View Composer\vmware-sviconfig.log. Das Upgrade-Skript protokolliert eine Nachricht für jeden Fehler.
- Prüfen Sie die Protokolleinträge, um die Desktops zu ermitteln, die nicht aktualisiert werden konnten.
Option |
Aktion |
Der Desktop ist vorhanden, jedoch nicht verfügbar. |
Stellen Sie die Verfügbarkeit des Desktops wieder her. Je nach der Ursache des Fehlers müssen Sie möglicherweise den ESXi-Host oder vCenter Server neu starten oder eine andere Aktion durchführen. |
Der Desktop ist nicht vorhanden. |
Ignorieren Sie die Protokollnachricht.
Hinweis: Ein gelöschter Desktop kann scheinbar in
Horizon Administrator vorhanden sein, wenn ein Administrator die virtuelle Desktop-Maschine direkt in vSphere löscht.
|
- Führen Sie den Befehl SviConfig databaseupgrade erneut aus.