Ein Sicherheitsserver oder eine View-Verbindungsserver-Instanz, die für sichere Horizon Client-Verbindungen verwendet wird, kann in View Administrator rot angezeigt werden, wenn eine Zertifikatssperrüberprüfung beim SSL-Zertifikat des Servers nicht durchgeführt werden kann.

Problem

Ein Sicherheitsserver- oder View-Verbindungsserver-Symbol ist im View Administrator-Dashboard rot. Der Status des View-Servers meldet Folgendes: Das Serverzertifikat kann nicht geprüft werden.

Ursache

Die Zertifikatssperrüberprüfung kann fehlschlagen, wenn Ihr Unternehmen für den Internetzugriff einen Proxy-Server verwendet oder wenn eine View-Verbindungsserver-Instanz die Server, die die Sperrüberprüfung durchführen, aufgrund von Firewalls oder anderen Kontrollen nicht erreichen kann.

Eine View-Verbindungsserver-Instanz führt die Zertifikatssperrüberprüfung für ihr eigenes Zertifikat und für das der Sicherheitsserver durch, die mit ihr kombiniert sind. Der VMware View-Verbindungsserver-Dienst wird standardmäßig mit dem Konto LocalSystem gestartet. Wenn sie unter LocalSystem ausgeführt wird, kann eine View-Verbindungsserver-Instanz die Proxy-Einstellungen, die im Internet Explorer konfiguriert sind, nicht für den Zugriff auf die CRL DP URL oder den OCSP-Antwortdienst verwenden, um den Widerrufstatus des Zertifikats zu ermitteln.

Sie können die Microsoft Netshell-Befehle verwenden, um die Proxy-Einstellungen in die View-Verbindungsserver-Instanz zu importieren, sodass der Server auf die Websites für die Zertifikatssperrüberprüfung im Internet zugreifen kann.

Lösung

  1. Öffnen Sie auf dem View-Verbindungsserver-Computer ein Befehlszeilenfenster mit der Einstellung Als Administrator ausführen.

    Klicken Sie beispielsweise auf Start, geben Sie cmd ein, klicken Sie mit der rechten Maustaste auf das Symbol cmd.exe und wählen Sie Als Administrator ausführen aus.

  2. Geben Sie netsh ein und drücken Sie die Eingabetaste.
  3. Geben Sie winhttp ein und drücken Sie die Eingabetaste.
  4. Geben Sie show proxy ein und drücken Sie die Eingabetaste.

    Netshell zeigt an, dass der Proxy auf DIREKT-Verbindung einstellt war. Bei dieser Einstellung kann der View-Verbindungsserver-Computer keine Verbindung zum Internet herstellen, wenn Ihr Unternehmen einen Proxy verwendet.

  5. Konfigurieren Sie die Proxy-Einstellungen.

    Geben Sie z. B. an der Eingabeaufforderung netsh winhttp> die Zeichenfolge import proxy source=ie ein.

    Die Proxy-Einstellungen werden auf den View-Verbindungsserver-Computer importiert.

  6. Überprüfen Sie die Proxy-Einstellungen durch Eingabe von show proxy.
  7. Restart the VMware Horizon View-Verbindungsserver service.
  8. Überprüfen Sie im View Administrator-Dashboard, dass das Sicherheitsserver- oder View-Verbindungsserver-Symbol grün ist.