Sie können die Optionen für die H.264-Decodierung und für die Netzwerkbedingung für Remote-Desktop- und -anwendungssitzungen konfigurieren, die das VMware Blast-Anzeigeprotokoll verwenden.

Warum und wann dieser Vorgang ausgeführt wird

Die maximal unterstützte Auflösung hängt von der Kapazität des Grafikprozessors (GPU, Graphical Processing Unit) auf dem Client ab. Eine GPU, die die 4K-Auflösung für JPEG/PNG unterstützt, unterstützt nicht zwangsläufig auch die 4K-Auflösung für H.264. Wird die Auflösung für H.264 nicht unterstützt, verwendet Horizon Client stattdessen JPEG/PNG.

Die H.264-Decodierung wird für AMD, NVIDIA und Intel GPUs unterstützt. Für die H.264-Decodierung ist die Installation der Grafikbibliothek OpenGL 3.2 oder höher für AMD- und NVIDIA-GPUs erforderlich.

Wenn Sie die H.264-Decodierung mit einer NVIDIA-GPU verwenden möchten, installieren Sie VDPAU (Video Decode and Presentation API for Unix). VDPAU ist im aktuellsten NVIDIA-Treiber nicht mehr enthalten und muss separat installiert werden.

Um H.264 mit einer Intel GPU verwenden zu können, müssen der Intel VA-API-Treiber und die GLX VA-API-Bibliothek vorhanden sein. Mit dem Befehl vainfo können Sie die H.264-Profile darstellen. Liegt der VA-API-Treiber in der Version 1.2.x oder früher vor, müssen Sie /etc/vmware/config, /usr/lib/vmware/config oder ~/.vmware/config den Eintrag mks.enableGLBasicRenderer = TRUE hinzufügen. Die Konfigurationsdateien werden in der folgenden Reihenfolge verarbeitet:

  1. /etc/vmware/config

  2. /usr/lib/vmware/config

  3. ~/.vmware/config

Mit Red Hat 7.2, Intel GPU, Intel-Treiber in der Version 1.2 oder früher, OpenGL 3.2 und aktivierter H.264-Decodierung müssen Sie einer der drei Konfigurationsdateien die nachfolgend aufgeführten Einträge hinzufügen, um Anzeigeprobleme wie z. B. einen schwarzen Bildschirm zu vermeiden.

mks.enableGLRenderer=FALSE
mks.enableGLBasicRenderer=TRUE

H.264 wird nicht für SLED 11 SP4 mit Intel GPU unterstützt, da die xorg-Version zu alt ist.

Die Option für die Netzwerkbedingung lässt sich nach der Anmeldung bei einem Server nicht mehr ändern. Die H.264-Decodierung können Sie vor und nach der Anmeldung bei einem Server konfigurieren.

Voraussetzungen

Diese Funktion erfordert Horizon Agent 7.0 oder höher.

Prozedur

  1. Wählen Sie Datei > VMware Blast konfigurieren in der Menüleiste aus.
  2. Konfigurieren Sie die Optionen für das Decodieren und die Netzwerkbedingung.

    Option

    Aktion

    H.264

    Sie können diese Option vor oder nach der Herstellung einer Verbindung mit dem Verbindungsserver konfigurieren, um die H.264-Decodierung in Horizon Client aktivieren.

    Ist diese Option ausgewählt (Standardeinstellung), verwendet Horizon Client die H.264-Decodierung, wenn der Agent die H.264-Software- oder -Hardwarecodierung unterstützt. Unterstützt der Agent die H.264-Software- oder -Hardwarecodierung nicht, verwendet Horizon Client die JPG/PNG-Decodierung.

    Deaktivieren Sie diese Option, um die JPG/PNG-Decodierung zu verwenden.

    Netzwerkstatus auswählen, um optimale Funktion zu gewährleisten

    Sie können diese Option nur vor der Herstellung einer Verbindung mit dem Verbindungsserver konfigurieren. Wählen Sie eine der folgenden Optionen für die Netzwerkbedingung aus:

    • HervorragendHorizon Client verwendet nur das TCP-Netzwerk. Diese Option ist am besten für eine LAN-Umgebung geeignet.

    • Normal (Standard)Horizon Client arbeitet im gemischten Modus. Im gemischten Modus verwendet Horizon Client das TCP-Netzwerk für die Herstellung einer Verbindung mit dem Server und das Protokoll Blast Extreme Adaptive Transport (BEAT), wenn der Agent und das Blast Security Gateway (bei Aktivierung) eine BEAT-Konnektivität unterstützen. Diese Option ist die Standardeinstellung.

    • SchlechtHorizon Client verwendet nur das BEAT-Netzwerk, wenn BEAT Tunnel Server auf dem Server aktiviert ist. Ist dies nicht der Fall, wird in den gemischten Modus gewechselt.

    Anmerkung:

    In Horizon 7 Version 7.1 und früher wird BEAT Tunnel Server von den Instanzen des Verbindungsservers und des Sicherheitsservers nicht unterstützt. Unified Access Gateway 2.9 und höher unterstützt BEAT Tunnel Server.

    Blast Security Gateway für Verbindungsserver- und Sicherheitsserver-Instanzen unterstützt nicht das BEAT-Netzwerk.

  3. Klicken Sie auf OK, um Ihre Änderungen zu speichern.

Ergebnisse

Änderungen für H.264 werden wirksam, wenn das nächste Mal ein Benutzer eine Verbindung mit einem Remote-Desktop oder einer Remoteanwendung herstellt und das VMware Blast-Anzeigeprotokoll auswählt. Ihre Änderungen haben keinen Einfluss auf vorhandene VMware Blast-Sitzungen.