Selbst wenn Sie beim Konvertieren der Image-VM in ein veröffentlichtes Image Schritte ausgeführt haben, um Microsoft Sysprep-Probleme zu verhindern, wird die Konvertierungsaufgabe bei einem nachfolgenden Versuch mit Zeitüberschreitung abgebrochen.

Problem

Beim ersten Versuch, das Image zu veröffentlichen, sehen Sie auf der Aktivitätsseite, dass der Image-Konvertierungsvorgang mit einem Zeitüberschreitungsfehler aufgrund von Microsoft Sysprep-Problemen im Zusammenhang mit Appx-Paketen fehlschlägt. Nachdem Sie die in Anpassen des Windows-Betriebssystems der importierten VM beschriebenen Optimierungsschritte ausgeführt und alle in den Microsoft-Sysprep-Fehlerprotokollen beschriebenen Probleme behoben haben, versuchen Sie, das Image zu konvertieren. Bei diesem zweiten Versuch sehen Sie Meldungen der folgenden Art auf der Aktivitätsseite: „20 Minuten auf das Ausschalten der virtuellen Maschine gewartet: Konvertieren Sie das Image zurück in die virtuelle Maschine“.

Ursache

Diese Situation tritt auf, weil der zweite Versuch, den Microsoft Sysprep-Prozess auszuführen, blockiert ist oder nicht reagiert. Führen Sie die folgenden Schritte aus, um das Problem zu umgehen.

Lösung

  1. Stellen Sie sicher, dass Sie die Microsoft Sysprep-Probleme gemäß den Fehlermeldungen in den Microsoft Sysprep-Fehlerprotokollen und Microsoft KB 2769827 beheben.
  2. Überprüfen Sie in der Image-VM den VMware Horizon Agent-Dienst und stellen Sie sicher, dass die Startart auf Automatisch festgelegt ist.
    Wenn sich das Image in einem Pod mit einem Manifest vor 1600 befindet, verfügt die VM auch über den VMware DaaS Agent-Dienst. Stellen Sie sicher, dass für den VMware DaaS Agent-Dienst der Starttyp auf Automatisch festgelegt ist.
  3. Starten Sie die Image-VM neu.
  4. Versuchen Sie den Konvertierungsprozess auf der neu gestarteten VM erneut.