Wenn Probleme mit Zertifikaten auf einer Verbindungsserver-Instanz vorliegen, können Sie keine Verbindung mit Horizon Console herstellen, oder der Systemzustand des Servers wird rot angezeigt.

Problem

Auf der Verbindungsserver-Instanz, auf der das Problem auftritt, können Sie keine Verbindung mit Horizon Console herstellen. Wenn Sie auf einer anderen Verbindungsserver-Instanz im selben Pod eine Verbindung mit Horizon Console herstellen, wird der Systemzustand der problematischen Verbindungsserver-Instanz im Dashboard rot angezeigt.

Wenn Sie von der anderen Verbindungsserver-Instanz aus auf die rote Anzeige des Systemzustands klicken, wird SSL-Zertifikat: Ungültig und Status: (leer) angezeigt. Dies weist darauf hin, dass kein gültiges Zertifikat gefunden werden konnte. Die VMware Horizon 8-Protokolldatei enthält einen Eintrag des Typs FEHLER mit folgender Meldung: Keine passenden Zertifikate im Schlüsselspeicher.

Die VMware Horizon 8-Protokolldaten befinden sich in <Laufwerksbuchstabe>:\ProgramData\VMware\log\ConnectionServer auf der Verbindungsserver-Instanz.
Hinweis: Dieser Dateipfad ist ein symbolischer Link, der auf den tatsächlichen Speicherort der Protokolldateien verweist, der <Laufwerksbuchstabe>:\ProgramData\VMware\VDM\logs lautet.

Ursache

Wenn ein Zertifikat nicht ordnungsgemäß auf einem VMware Horizon 8-Server installiert ist, kann dies einen der folgenden Gründe haben:

  • Das Zertifikat befindet sich nicht im Ordner „Persönlich“ des lokalen Windows-Zertifikatspeichers auf dem Computer.
  • Der Zertifikatspeicher hat keinen privaten Schlüssel für das Zertifikat.
  • Das Zertifikat hat nicht den Anzeigenamen vdm.
  • Das Zertifikat wurde anhand einer v3-Zertifikatvorlage für einen Windows Server 2008 oder höher erzeugt. VMware Horizon 8 kann keinen privaten Schlüssel erkennen. Wenn Sie jedoch das Zertifikat-Snap-In zum Durchsuchen des Windows-Zertifikatspeichers verwenden, wird im Speicher ein privater Schlüssel gefunden.

Lösung