Das Installationsprogramm für den Verbindungsserver weist bestimmte Einschränkungen auf, die die Installation des Verbindungsservers blockieren können, wenn Sie die Verbindungsserver parallel aktualisieren. Diese Einschränkungen gelten auch für die Upgrades einzelner Verbindungsserver und Neuinstallationen von Replikatservern.

Problem

Wenn Sie bei der Durchführung eines Upgrades oder der Installation von Verbindungsservern die Verbindungsserver-Installationsprogramme ausführen, kann das Verbindungsserver-Installationsprogramm Fehlermeldungen anzeigen und den Installationsvorgang blockieren.

Ursache

Installations- oder Upgradefehler für den Verbindungsserver können auftreten, wenn der Schema-Master-Knoten nicht verfügbar ist oder aus dem LDAP-Server entfernt wird. Der Schema-Master-Knoten wird gelöscht, wenn eine Verbindungsserver-Instanz mithilfe des Befehls vdmadmin -S ohne saubere Deinstallation von LDAP-Instanzen entfernt wird.

Lösung

  1. Wenn der Installationsfehler aufgrund der Nichtverfügbarkeit des Schema-Master-Knotens auftritt, schalten Sie alle Knoten im LDAP-Server ein, die in der Fehlermeldung angegeben sind.
    Wenn das Aktivieren aller Knoten im LDAP-Server das Problem nicht löst, kann es sein, dass der Fehler auftritt, weil der Schema-Master-Knoten aus dem Cluster entfernt wurde. Fahren Sie mit Schritt 2 fort, um den Fehler zu beheben.
  2. Wenn der Schema-Master-Knoten aus dem LDAP-Cluster entfernt wird, müssen Sie einen anderen Knoten als Schema-Master-Knoten im Cluster erstellen. Die zur Umwandlung eines anderen Knotens in den Schema-Master-Knoten des Clusters erforderlichen Schritte hängen davon ab, ob einer oder keiner der Knoten auf die neue Version von VMware Horizon 8 aktualisiert wurde oder ob Sie versuchen, ein neues Verbindungsserver-Replikat zu installieren.
    • Wenn ein beliebiger Knoten auf die neue Version von VMware Horizon 8 im Cluster aktualisiert wird, können Sie den Befehl vdmadmin -X verwenden, um den aktuellen Knoten in den Schemamaster-Knoten umzuwandeln.

      Wenn Sie versuchen, eine neue Replikatinstanz zu installieren, führen Sie den Befehl vdmadmin -X auf einer anderen Verbindungsserver-Instanz in dem Cluster aus, der über Netzwerkkonnektivität mit dem Replikatknoten verfügt.

      • Geben Sie den folgenden Befehl ein, um den aktuellen Knoten als Schema-Master-Knoten im Cluster für eine lokale LDAP-Instanz zu erstellen:
        vdmadmin -X -seizeSchemaMaster
      • Geben Sie den folgenden Befehl ein, um den aktuellen Knoten als Schema-Master-Knoten im Cluster für eine globale LDAP-Instanz in einer Cloud-Pod-Architektur-Umgebung zu erstellen:
        vdmadmin -X -seizeSchemaMaster -global

      Weitere Informationen zum Befehl vdmadmin -X finden Sie unter „Ermitteln und Lösen von Konflikten bei LDAP-Einträgen und LDAP-Schemas mithilfe der Option ‚-X‘“ im Dokument Horizon-Verwaltung.

    • Wird keiner der Knoten auf die neue Version von VMware Horizon 8 im Cluster aktualisiert, verwenden Sie den Befehl dsmgmt, um den aktuellen Knoten in den Schemamaster-Knoten umzuwandeln.
      • Geben Sie den folgenden Befehl ein, um den aktuellen Knoten als Schema-Master-Knoten im Cluster für eine lokale LDAP-Instanz zu erstellen:
        dsmgmt "roles" "connections" "connect to server localhost:389" "quit" "transfer schema master" "quit" "quit"
      • Geben Sie den folgenden Befehl ein, um den aktuellen Knoten als Schema-Master-Knoten im Cluster für eine globale LDAP-Instanz in einer Cloud-Pod-Architektur-Umgebung zu erstellen:
        dsmgmt "roles" "connections" "connect to server localhost:22389" "quit" "transfer schema master" "quit" "quit"
    Wenn der aktuelle Knoten als Schema-Master-Knoten das Problem nicht behebt, kann der Fehler auftreten, weil die LDAP-Instanz während eines Fehlers beim Übertragen der Schema-Master-Rolle gesperrt wurde. Fahren Sie mit Schritt 3 fort, um den Fehler zu beheben.
  3. Entfernen Sie die Sperren für die LDAP-Instanz.
    • Um die Sperren für eine lokale LDAP-Instanz zu entfernen, geben Sie den folgenden Befehl ein:
      vdmadmin -X -deleteSchemaMasterLocks
    • Um die Sperren für eine globale LDAP-Instanz in einer Cloud-Pod-Architektur-Umgebung zu entfernen, geben Sie den folgenden Befehl ein:
      vdmadmin -X -deleteSchemaMasterLocks -global