Benutzer können aus dem Workspace ONE-Portal keine Anwendungen starten oder in einer Umgebung mit Lastausgleich wird die falsche Authentifizierungsmethode angewendet.

Problem

In einer Umgebung mit Lastausgleich können Probleme wie die folgenden auftreten:

  • Benutzer können nach dem Anmelden keine Anwendungen aus dem Workspace ONE-Portal starten.

  • Den Benutzern wird zur erweiterten Authentifizierung die falsche Authentifizierungsmethode präsentiert.

Ursache

Dieses Problem kann auftreten, wenn Zugriffsrichtlinien falsch festgelegt werden. Die Client-IP-Adresse legt fest, welche Zugriffsrichtlinie beim Anmelden und beim Starten von Anwendungen angewendet wird. In einer Umgebung mit Lastausgleich verwendet VMware Identity Manager die „X-Forwarded-For“-Kopfzeile zur Festlegung der Client-IP-Adresse. In einigen Fällen kann ein Fehler auftreten.

Lösung

Legen Sie die service.numberOfLoadBalancers-Eigenschaft in der runtime-config.properties-Datei in jedem der Knoten in Ihrem VMware Identity Manager-Cluster fest. Mit der Eigenschaft wird die Anzahl der Lastausgleichsdienste vor den VMware Identity Manager-Instanzen angegeben.

Anmerkung:

Das Festlegen dieser Eigenschaft ist optional.

  1. Melden Sie sich an der VMware Identity Manager-Appliance an.

  2. Bearbeiten Sie die Datei /usr/local/horizon/conf/runtime-config.properties und fügen Sie die folgende Eigenschaft hinzu.

    service.numberOfLoadBalancers numberOfLBs

    wobei numberOfLBs die Anzahl der Lastausgleichsdienste vor den VMware Identity Manager-Instanzen angibt.

  3. Starten Sie die Workspace-Appliance neu.

    service horizon-workspace restart