Der L2VPN-Tunnel zwischen Server und Client ist aktiv, es gibt jedoch keinen Datenfluss durch den Tunnel.
Die Schritte im folgenden Verfahren gelten für den L2 VPN-Dienst unter Verwendung von SSL-Tunneln und IPSec-Tunneln.
Problem
Es gibt Probleme mit der Konnektivität im Datenpfad zwischen dem L2VPN-Server und dem L2VPN-Client.
Ursache
Es hat möglicherweise einen der folgenden Gründe, warum kein Datenverkehr im L2VPN-Tunnel fließt:
- Die Tunnel-ID des eigenständigen L2VPN-Clients stimmt nicht mit der auf dem L2VPN-Server konfigurierten Tunnel-ID überein.
- Die vNIC-Schnittstelle muss dem Trunk-Port des Distributed Switch nicht zugewiesen sein, damit eine Verbindung mit der virtuellen eigenständigen L2VPN-Edge-Appliance hergestellt werden kann.
- Die in der Uplink-Schnittstelle der VM konfigurierte VLAN-ID liegt außerhalb des VLAN-Bereichs der Trunk-Portgruppe auf dem Distributed Switch der eigenständigen L2VPN-Edges.
- Möglicherweise ist Sink nicht für die Portnummer der mit der eigenständigen L2VPN-Edge-Appliance verbundenen Trunk-Schnittfläche aktiviert.
Lösung
- Um zu überprüfen, ob die Tunnel-ID des L2VPN-Clients mit der Tunnel-ID des L2VPN-Servers übereinstimmt, melden Sie sich bei der Befehlszeilenschnittstelle der eigenständigen L2VPN-Appliance an. Führen Sie den Befehl show service l2vpn conversion-table aus.
- Um zu überprüfen, ob dem Trunk-Port des Distributed Switch eine vNIC-Schnittstelle zur Verbindung mit der eigenständigen L2 VPN-Edge-Appliance zugewiesen ist, führen Sie in vSphere Web Client die folgenden Schritte aus.
- Klicken Sie auf Hosts und Cluster (Hosts and Clusters).
- Klicken Sie mit der rechten Maustaste auf das eigenständige L2VPN-Edge und klicken Sie auf Einstellungen bearbeiten (Edit Settings).
- Stellen Sie sicher, dass Sie sich auf der Registerkarte Virtuelle Hardware (Virtual Hardware) befinden.
- Stellen Sie im Dropdown-Menü Netzwerkadapter 2 (Network adapter 2) sicher, dass der Trunk-Port des Distributed Switch ausgewählt und das Kontrollkästchen Verbunden (Connected) aktiviert ist.
- Um den VLAN-Trunk-Bereich für die Trunk-Portgruppe des Distributed Switch zu überprüfen, führen Sie in vSphere Web Client die folgenden Schritte aus.
- Klicken Sie auf Hosts und Cluster (Hosts and Clusters).
- Klicken Sie auf die Registerkarte Netzwerk (Networking).
- Klicken Sie mit der rechten Maustaste auf die Trunk-Portgruppe des Distributed Switch und klicken Sie dann auf Einstellungen bearbeiten (Edit Settings).
- Öffnen Sie die Seite „VLAN“.
- Stellen Sie sicher, dass der VLAN-Bereich in der Trunk-Portgruppe die VLAN-ID umfasst, die Sie im Uplink-Port der VM angegeben haben, von der der Datenverkehr ausgeht.
Hinweis: Sie müssen möglichst über eine dedizierte Portgruppe auf dem Distributed Switch verfügen, die für das VLAN-Trunking konfiguriert ist, sodass eine Verbindung zur Edge-Appliance hergestellt werden kann.
- Um zu überprüfen, ob Sink für die Portnummer der Trunk-Portgruppe aktiviert ist, von der aus eine Verbindung zur eigenständigen L2 VPN-Edge-Appliance hergestellt wird, führen Sie in vSphere Web Client die folgenden Schritte aus.
- Klicken Sie auf Hosts und Cluster (Hosts and Clusters).
- Klicken Sie auf die Registerkarte Netzwerk (Networking).
- Klicken Sie auf die Trunk-Portgruppe des Distributed Switch und anschließend auf die Registerkarte Ports.
- Suchen Sie nach der mit der eigenständigen L2VPN-Appliance verbundenen Portnummer oder Port-ID.
- Melden Sie sich bei der Befehlszeilenschnittstelle (CLI) des ESXi-Hosts an, auf dem der eigenständige L2VPN-Client bereitgestellt wurde, und führen Sie den folgenden Befehl aus, um festzustellen, ob Sink für diese Portnummer aktiviert ist:
net-dvs -l | grep "port\ [0-9]\|SINK\|com.vmware.common.alias"
Wenn Sink beispielsweise für Port 30 aktiviert ist, zeigt die CLI des ESXi-Hosts die folgende Ausgabe an:port 30:com.vmware.etherswitch.port.extraEthFRP = SINK