Beim Upgrade von NSX Intelligence mit NSX Manager Unified Appliance 2.5.x schlägt der Upgradevorgang möglicherweise beim Schritt zur Registrierung des UI-Plug-Ins fehl.

Problem

Entweder eine Änderung der IP-Adresse oder des Zertifikats des NSX ManagerUnified Appliance-Knotens kann dazu geführt haben, dass die Registrierung des UI-Plug-Ins fehlschlägt. Nachdem das Upgrade in der NSX Intelligence-CLI-Sitzung fehlgeschlagen ist, wird bei der Überprüfung des Upgradestatus der aufgetretene Fehler angezeigt, wie in der folgenden Beispielausführung des Befehls „get upgrade progress-status“ gezeigt.
nsx-intelligence> get upgrade progress-status
...output snipped...
Upgrade step status:
Name: update_plugin_registration
State: TASK_FAILURE

Errors:
Registration of node failed with status code 400

Status file:
wait_for_intelligence_server: resp_status: 200, body: b'{"results":[{"_links":[],"_revision":0,"_create_user":"admin","_create_time":1581934303820,"_last_modified_user":"admin","_last_modified_time":1581934303820,"_system_owned":false,"id":"default","path":"endpoints/default","end_point_address":"20.20.0.11","protocol":"https","thumbprint":"2d7efed079858e3b9d8b83647f38e48c177d56cbb1ab6669a8d63899be0a5206"}]}'
Node Registration response - 400, b'{"error_code":400,"module_name":"common-service","error_message":"I/O error on GET request for \\\\\\"https://20.20.0.11/api/v1/node/version\\\\\\": No route to host (Host unreachable); nested exception is java.net.NoRouteToHostException: No route to host (Host unreachable)"}'
Das folgende Fehler-Snippet in der Datei /var/log/Resume-Upgrade.log enthält auch Informationen zum Fehler bei der Registrierung des UI-Plug-Ins.
...output snipped...
2020-03-26 15:26:07,291 - Playbook failed at step update_plugin_registration. Run the command 'set debug-mode' followed by 'start upgrade-bundle VMware-NSX-Intelligence-appliance-1.1.0.0.0.15898874 step get_upgrade_task_history' for more info.
{
  "info": "[MUS] UpgradeError: Playbook failed at step update_plugin_registration. Run the command 'set debug-mode' followed by 'start upgrade-bundle VMware-NSX-Intelligence-appliance-1.1.0.0.0.15898874 step get_upgrade_task_history' for more info.",
  "state_text": "CMD_ERROR",
  "state": 2,
  "body": null
}

Ursache

Dieses Problem kann auftreten, wenn die Informationen über den NSX Manager Unified Appliance-Knoten sich von denen unterscheiden, die in der NSX Intelligence-Appliance gespeichert sind. Die IP-Adresse oder das Zertifikat des NSX Manager Unified Appliance-Knotens wurde möglicherweise seit der letzten Installation der NSX Intelligence-Appliance geändert.

Lösung

Aktualisieren Sie die Angaben zur IP-Adresse, zum Zertifikat und zum Zertifikatfingerabdruck des NSX Manager Unified Appliance-Knotens, bevor Sie mit dem Upgrade von NSX Intelligence fortfahren. Verwenden Sie die im VMware Knowledge Base-Artikel https://kb.vmware.com/s/article/78505 bereitgestellten Informationen, um dieses Problem zu beheben.