NSX Container Plug-in (NCP) weist folgende Kompatibilitätsanforderungen für eine Kubernetes-Umgebung und eine Pivotal Cloud Foundry(PCF)-Umgebung auf.

Tabelle 1. Kompatibilitätsanforderungen für eine Kubernetes-Umgebung
Softwareprodukt Version
NSX-T Data Center 2.3, 2.4
Hypervisor für Container-Host-VMs
Container-Host-Betriebssystem
  • RHEL 7.5, 7.6
  • Ubuntu 16.04
  • CentOS 7.4, 7.5
Container-Orchestrator Kubernetes 1.12, 1.13
Container-Host-Open vSwitch 2.9.1 (im Lieferumfang von NSX-T Data Center 2.3.x), 2.10.2 (im Lieferumfang von NSX-T Data Center 2.4.0)
Tabelle 2. Kompatibilitätsanforderungen für eine Cloud Foundry-Umgebung
Softwareprodukt Version
Hypervisor für Container-Host-VMs
Container-Orchestrator
  • Pivotal Application Service 2.3.x und Pivotal Operations Manager 2.3.x
  • Pivotal Application Service 2.4.x (außer 2.4.0) und Pivotal Operations Manager 2.4.x (außer 2.4.0)