Der NSX Network Detection and Response-Aktivierungsassistent meldet einen Fehler, nachdem versucht wurde, die NSX Cloud Connector-Komponente bereitzustellen.
Problem
Im Rahmen der Aktivierung der NSX Network Detection and Response-Funktion versucht der Aktivierungsassistent, die NSX Cloud Connector-Komponente bereitzustellen. Der NSX Cloud Connector registriert die NSX-Installation beim NSX Advanced Threat Prevention-Cloud-Dienst und erstellt einen sicheren Kanal zwischen den lokalen Ressourcen und den Cloud-Ressourcen. Wenn während dieser Schritte ein Problem auftritt, meldet der Aktivierungsassistent einen NSX Cloud Connector-Bereitstellungsfehler, der die Fortsetzung der NSX Network Detection and Response-Aktivierung blockiert und schließlich zum Abbruch führt.
Ursache
Der NSX Cloud Connector stellt die Konnektivität mit der von Ihnen ausgewählten NSX Advanced Threat Prevention-Cloud-Dienstregion her und löst die Registrierung mithilfe der NSX-Lizenzen aus. Wenn die Verbindung nicht verfügbar ist, schlägt die Registrierung fehl oder es tritt eine Zeitüberschreitung auf.
Lösung
- Der NSX Cloud Connector verwendet denselben Kommunikationskanal, der zuvor während der Vorabprüfung der NSX Network Detection and Response-Aktivierung validiert wurde. Wenn sich die NSX-Konfiguration zwischen dem Ausführen der NSX Network Detection and Response-Vorabprüfung und der tatsächlichen NSX Network Detection and Response-Aktivierung geändert hat, führen Sie die Aktivierungsvorprüfung erneut aus. Wenn ein Fehler auftritt, befolgen Sie die Informationen zur Fehlerbehebung für den Fehler bei der Aktivierungsvorprüfung.
- Stellen Sie sicher, dass NSX Application Platform korrekt bereitgestellt und auf der Benutzeroberflächenseite als STABIL angezeigt wird.
- Überprüfen Sie die Protokolle für den NSX Cloud Connector-Registrierungsdienst.
- Erfassen Sie ein NSX Application Platform-Support-Paket und überprüfen Sie die Protokolle für jeden Kubernetes-Pod dessen Name mit cloud-connector-register beginnt.
- Alternativ können die Protokolle auch interaktiv auf der NSX Manager-Appliance abgefragt werden, indem Sie die folgenden Schritte ausführen.
- Melden Sie sich bei der NSX Manager-Appliance als root an.
- Verwenden Sie den folgenden Befehl, um die Kubernetes-Konfiguration für alle nachfolgendenhelm- und kubectl-Aufrufe zu markieren.
export KUBECONFIG=/config/vmware/napps/.kube/config
- Stellen Sie mit dem folgenden Befehl sicher, dass das Helm-Diagramm des NSX Cloud Connector erfolgreich bereitgestellt wurde.
helm --namespace nsxi-platform list --all --filter 'cloud-connector'
Stellen Sie sicher, dass die Eigenschaft STATUS Bereitgestellt angezeigt wird. - Überprüfen Sie, ob der Registrierungs-Pod bereitgestellt und erfolgreich abgeschlossen wurde.
kubectl --namespace nsxi-platform get pods --selector='job-name=cloud-connector-register'
Der Pod sollte STATUS als Abgeschlossen anzeigen. - Überprüfen Sie die Ereignisse für den Registrierungs-Pod mithilfe des folgenden Befehls.
kubectl --namespace nsxi-platform describe pod --selector='job-name=cloud-connector-register'
Der Abschnitt „Ereignisse“ enthält den Status der Registrierungsaufgabe und die mit der Aufgabe verbundenen Aktionen. - Verwenden Sie den folgenden Befehl, um die Protokolle für den Registrierungs-Pod zu überprüfen.
kubectl --namespace nsxi-platform logs --selector='job-name=cloud-connector-register' --container=main
- Klicken Sie nach dem Beheben des Fehlers auf Aktionen in der NSX Network Detection and Response-Funktionskarte. Wählen Sie Löschen um das Löschen der teilweise aktivierten NSX Network Detection and Response-Funktion zu initiieren. Versuchen Sie nach Abschluss des Löschvorgangs erneut, die Funktion zu aktivieren.