Problem
Nichtübereinstimmung der Anmeldedaten nach dem Ändern NSX Advanced Load Balancer-Controller-Kennworts.
Ursache
Wenn Sie das Controller-Kennwort für den Admin-Benutzer von außerhalb von NSX-T über die Avi Vantage Platform-Benutzeroberfläche ändern, wird das neue Kennwort in NSX-T nicht aktualisiert. Änderungen des Kennworts außerhalb von NSX-T werden in NSX Manager nicht widergespiegelt. NSX Manager spiegelt nicht den Status des Clusters wider.
Lösung
- Melden Sie sich in einem Browser mit Administratorrechten bei einem NSX Manager unter https://<nsx-manager-ip-address> an.
- Wenn Sie das Kennwort außerhalb von NSX-T geändert haben, führen Sie die folgende API aus, um das Kennwort zu ändern.
PUT https://<NSX-Manager-IPaddress>/api/v1/alb/controller-nodes/deployments/<node_id>
{
"form_factor": "SMALL",
"user_settings": {
"admin_password": "Tilak@123456"
},
"deployment_config": {
"vc_id": "755bd5cb-3700-456c-b74e-25f5140f4a50",
"compute_id": "domain-c201",
"host_id": null,
"storage_id": "datastore-206",
"management_network_id": "network-207",
"hostname": "controller-AA",
"placement_type": "AlbControllerVsphereClusterNodeVmDeploymentConfig",
"disk_provisioning": "THIN",
"dns_servers": [
"8.8.8.8"
]
}
}
- Wenn Sie das Kennwort von NSX-T geändert haben, führen Sie die folgende API aus, um Kennwort, DNS und NTP-Server in NSX-T und auf dem NSX Advanced Load Balancer Controller zu ändern.
PUT https://<NSX-Manager-IPaddress>/api/v1/alb/controller-nodes/deployments/<node-ID>?running_config=true