Problem

Löschen des NSX Advanced Load Balancer-Controllers nicht möglich.

Ursache

Wenn NSX Advanced Load Balancer-Objekte vorhanden sind und nur noch ein Knoten vorhanden ist, lässt NSX-T nicht zu, dass Sie alle bereitgestellten NSX Advanced Load Balancer-Controller-Knoten löschen. Dieses Problem tritt auf, weil NSX-T nicht auf den Knoten zugreifen kann oder weil Sie den Knoten manuell aus Compute Manager gelöscht haben.

Lösung

  1. Melden Sie sich in einem Browser mit Administratorrechten bei einem NSX Manager unter https://<nsx-manager-ip-address> an.
  2. Löschen Sie alle vorhandenen NSX Advanced Load Balancer-Objekte.
  3. Wenn Sie den Controller löschen möchten, wechseln Sie zu

    System > Appliances > NSX Advanced Load Balancer

  4. Klicken Sie auf Aktionen und dann auf Löschen oder Löschen erzwingen.
  5. Wenn Load Balancer-Objekte vorhanden sind, können Sie den im Cluster verbleibenden Controller-Knoten nicht löschen. Um den letzten Controller-Knoten zu löschen, führen Sie den folgenden API-Befehl aus.
    Hinweis: Übergeben Sie das inaccessible-Flag nur dann, wenn NSX-T nicht auf den Knoten zugreifen kann und es sich um den letzten Knoten im Cluster handelt.

    /policy/api/v1/alb/controller-nodes/deployments/{{node_id}}?action=delete&force_delete=true&inaccessible

    Der API-Befehl löscht den Controller-Knoten, aber die Load Balancer-Objekte sind weiterhin im System vorhanden.