Der NSX Application Platform-Bereitstellungsvorgang ist aufgrund einer Zeitüberschreitung fehlgeschlagen.

Problem

Ein NSX Application Platform-Bereitstellungsversuch konnte nicht abgeschlossen werden und es ist eine Zeitüberschreitung aufgetreten.

Ursache

Der NSX Application Platform-Bereitstellungsvorgang umfasst die Installation mehrerer Dienste, die für Messaging, Datenspeicher, Analyse usw. verwendet werden. Falls diese Dienste nicht innerhalb von 20 Minuten nach der Initiierung der Bereitstellung gestartet werden, wird der Bereitstellungsvorgang mit einem Zeitüberschreitungsfehler angehalten. Mögliche Ursachen für den Zeitüberschreitungsfehler sind Infrastrukturprobleme, z. B. CPU-Konflikte, Speicherkonflikte oder Probleme mit der Netzwerkkonnektivität.

Lösung

  1. Melden Sie sich mit dem Root-Konto bei der NSX Manager-Appliance an.
  2. Stellen Sie mithilfe des folgenden Befehls sicher, dass die nsxi-platform-Pods erfolgreich bereitgestellt wurden.
    napp-k get pods --selector='app.kubernetes.io/instance=nsxi-platform'

    Wenn der Pod-Status entweder Running oder Completed lautet, bedeutet dies, dass der Pod erfolgreich gestartet wurde.

    Wenn weiterhin einer der folgenden Pod-Status zurückgegeben wird, kann dies darauf hindeuten, dass ein Pod nicht erfolgreich gestartet wurde.
    • Init/Podinitializing/CrashLoopBackOff
    • Pending
    • ContainerCreating
    • ImagePullBackOff
    • ErrImagePull
    • ImageInspectError
    • CreateContainerConfigError
  3. Wenn einer der Pods nicht innerhalb von 20 Minuten nach der Initiierung der Bereitstellung gestartet wird und die Bereitstellung mit einem Zeitüberschreitungsfehler angehalten wird, untersuchen Sie, ob Probleme mit der Infrastruktur vorliegen, z. B. CPU-Konflikte, Speicherkonflikte oder Netzwerkkonnektivitätsprobleme. Beheben Sie die Probleme und wiederholen Sie die NSX Application Platform-Bereitstellung über die NSX Manager-Benutzeroberfläche.
  4. Wenn bei der Bereitstellung weiterhin Zeitüberschreitungen auftreten, verwenden Sie den folgenden Befehl, um die Protokolldateien für jeden Pod zu überprüfen, der nicht gestartet werden kann.
    Rufen Sie <POD_NAME> aus der Ausgabe des Befehls in Schritt 2 ab.
    napp-k logs <POD_NAME>
  5. Beheben Sie die in den Protokolldateien gemeldeten Fehler und wiederholen Sie die NSX Application Platform-Bereitstellung über die NSX Manager-Benutzeroberfläche.
  6. Wenn die Bereitstellung weiterhin fehlschlägt, wenden Sie sich an den VMware Support, um Unterstützung zu erhalten.