Das Upgrade der NSX Application Platform ist aufgrund eines Fehlers fehlgeschlagen.

Problem

Ein Versuch, die NSX Application Platform zu aktualisieren, ist mit dem Fehler Bereitstellen des Upgrade-Koordinators: Fehler beim Plug-In-Aufruf nach der Bereitstellung des Upgrade-Koordinators fehlgeschlagen.

Ursache

Wenn die Konnektivität zwischen dem Kubernetes-Steuerungsebenenknoten und einem vorhandenen Pod unterbrochen wird, kann der Kubernetes-Zertifikatmanager das Zertifikat nicht erfolgreich an den vorhandenen Pod senden, und die an NSX Manager gesendeten Egress-API-Aufrufe schlagen fehl. Dieses Problem kann auch auftreten, wenn ein Konnektivitätsproblem zwischen dem Update-Koordinatorknoten und dem Kubernetes-Steuerungsebenenknoten vorliegt.

Lösung

Um dieses Problem zu beheben, führen Sie die folgenden Schritte aus.

  1. Melden Sie sich mit dem root-Konto bei der NSX Manager-Appliance an.

  2. Führen Sie bei der Systemeingabeaufforderung den folgenden Befehl aus, um die Pods neu zu starten.

    napp-k rollout restart deployment cluster-api trust-manager 
  3. Warten Sie, bis die cluster-api- und trust-manager-Pods erfolgreich neu gestartet wurden.

  4. Sobald die Pods wieder online sind, starten Sie die Bereitstellung des Upgrade-Koordinators mit dem folgenden Befehl neu.

    napp-k rollout restart deployment upgrade-coordinator
  5. Warten Sie, bis der Upgrade-Koordinator erfolgreich neu gestartet wurde.

  6. Wiederholen Sie das NSX Application Platform-Upgrade mithilfe der Registerkarte System > Upgrade auf der Benutzeroberfläche von NSX Manager. Einzelheiten dazu finden Sie unter Aktualisieren der NSX Application Platform.