Konfigurieren Sie die Workspace ONE Access-Appliance so, dass sie auf den lokalen Webserver zeigt, um ein Offline-Upgrade durchzuführen. Führen Sie dann ein Upgrade für die Appliance durch.

Prozedur

  1. Melden Sie sich bei der Workspace ONE Access-Appliance als Root-Anwender an.
  2. Führen Sie den folgenden Befehl aus, um ein Upgrade-Repository zu konfigurieren, das einen lokalen Webserver verwendet.
    /usr/local/horizon/update/updatelocal.hzn seturl http://YourWebServer/VM/
    		  
    Hinweis: Um die Konfiguration rückgängig zu machen und die Möglichkeit wiederherzustellen, ein Online-Upgrade durchzuführen, können Sie den folgenden Befehl ausführen.
    /usr/local/horizon/update/updatelocal.hzn setdefault
  3. Führen Sie das Upgrade durch.
    1. Führen Sie folgenden updatemgr.hzn-Befehl aus.
      /usr/local/horizon/update/updatemgr.hzn updateinstaller
    2. Führen Sie folgenden Befehl aus.
      /usr/local/horizon/update/updatemgr.hzn update

      Während des Upgrades ausgegebene Meldungen werden in der Datei update.log unter dem Pfad /opt/vmware/var/log/update.log gespeichert.

    3. Geben Sie y ein, um mit dem Upgrade des Workspace ONE Access-Diensts fortzufahren, oder n, um das Upgrade zu beenden.
      Die Eingabeaufforderung bietet Ihnen die Möglichkeit, die folgenden Informationen zu virtuellen Apps zu berücksichtigen.
      Wichtig: Integrationen von Citrix, Horizon-Verbindungsserver und ThinApp sind mit dem Workspace ONE Access 20.01 Connector nicht verfügbar.
      • Zur Verwendung von ThinApp-Paketanwendungen benötigen Sie VMware Identity Manager Connector (Linux) 2018.8.1.0.
      • Zur Verwendung anderer virtueller Apps, wie z. B. Horizon-Desktops und -Anwendungen oder veröffentlichter Citrix-Ressourcen, benötigen Sie VMware Identity Manager Connector (Windows) 19.03.

      Sie können mit dem Upgrade fortfahren, wenn Sie virtuelle Apps verwenden möchten. Der Workspace ONE Access-Dienst 20.01 bietet Unterstützung für virtuelle Apps, der Workspace ONE Access Connector 20.01 hingegen nicht. Wenn Sie also beabsichtigen, virtuelle Apps mit dem Workspace ONE Access-Dienst 20.01 zu verwenden, können Sie kein Upgrade auf den Workspace ONE Access Connector 20.01 durchführen.

    4. Führen Sie erneut den updatemgr.hzn check-Befehl aus, um sich zu vergewissern, dass kein neueres Update vorhanden ist.
      /usr/local/horizon/update/updatemgr.hzn check
    5. Überprüfen Sie die Version der Appliance nach dem Upgrade.
      vamicli version --appliance
      Der Befehl sollte die neue Version anzeigen.
    6. Starten Sie die Appliance neu.
      Führen Sie beispielsweise an der Befehlszeile den folgenden Befehl aus.
      reboot

Ergebnisse

Damit ist die Aktualisierung abgeschlossen.

Siehe Konfigurieren nach dem Upgrade.