Die Synchronisierung der Citrix-Ressource schlägt fehl, wenn die Einstellung der Gruppe mit beschränkter Sichtbarkeit keine AD-Benutzer oder -Gruppen enthält.

Problem

In XenDesktop und XenApp 7.9 und höher schlägt die Synchronisierung mit Workspace ONE Access fehl, wenn die Einstellung für die Gruppe mit beschränkter Sichtbarkeit ausgewählt ist und wenn diese keine Benutzer oder Gruppen enthält.

Ursache

Die Gruppe mit beschränkter Sichtbarkeit muss, sofern sie festgelegt ist, Benutzer oder Gruppen enthalten.

Lösung

  1. Suchen Sie den tatsächlichen Namen der Anwendung durch Ausführen des folgenden PowerShell-Befehls:
    asnp citrix*

    Get-brokerapplication-browsername nameOfCitrixPublishedResource

    Suchen Sie in den Anwendungsdetails, die angezeigt werden, nach dem Namen der Anwendung.

  2. Suchen Sie in Citrix Studio die Anwendung mit diesem Namen, bearbeiten Sie die Eigenschaft „Beschränkte Sichtbarkeit“ und fügen Sie Benutzer und Gruppen zur Liste hinzu.