Ein Kommunikationsproblem zwischen Integration Broker und PowerShell SDK kann verhindern, dass von Citrix veröffentlichte Anwendungen und Desktops im Workspace ONE Access-Katalog angezeigt werden.

Sie können in einem Browser URLs angeben, um zu ermitteln, an welcher Stelle von Integration Broker ein Konfigurationsproblem besteht. Mit dieser Fehlerbehebungsmethode können Sie ermitteln, ob es sich um ein Konfigurationsproblem in den folgenden Bereichen handelt.
  • Citrix-Serverfarm
  • Von Citrix veröffentlichte Ressourcen
  • Ressourcenberechtigungen

Wenn eine Webseite nicht die erwartete Ausgabe anzeigt, gibt sie einen Fehler aus und fügt den Integration Broker-Protokollen Informationen hinzu. Überprüfen Sie die Integration Broker-Protokolle, um die Fehlerbehebung fortzusetzen.

Problem

Nachdem Sie Citrix in Workspace ONE Access integriert haben, werden von Citrix veröffentlichte Ressourcen nicht im Workspace ONE Access-Katalog angezeigt.

Ursache

Mit Integration Broker kann ein Konfigurationsproblem vorliegen, das die ordnungsgemäße Kommunikation mit PowerShell SDK verhindert.

Lösung

  1. Verwenden Sie einen Browser, um die Informationen zur Citrix-Serverfarm zu prüfen.
    1. Geben Sie in einem Browser eine URL ein, etwa eine der folgenden, und ersetzen Sie dabei die Platzhalter durch die konkreten Informationen.
      • Citrix Server Farm 7.x

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/xenfarminfo?computerName=XenAppServerHostname&xenappversion=Version7x

      • Citrix Server Farm 6.5

        https://IB-Hostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/xenfarminfo?computerName=XenAppServer-Hostname&xenappversion=Version65orLater

      • Citrix Server Farm 5.5 oder 6.0

        https://IB-Hostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/xenfarminfo?computerName=XenAppServer-Hostname&xenappversion=Legacy

    2. Überprüfen Sie den Inhalt der Webseite und bei Bedarf die Integration Broker-Protokolle.
      Wenn Integration Broker ordnungsgemäß konfiguriert ist, werden auf der Seite Informationen zur Citrix-Serverfarm angezeigt, darunter folgende:

      "[{\"FarmName\":\"Testdaten\",\"ServerVersion\":\" 6.0.6410\",\"AdministratorType\":\"Full\",\"SessionCount\":\"2\",\"MachineName\":\"Testdaten\"}]”

      Wenn auf einer Webseite keine Informationen zur Serverfarm erscheinen, werden Protokollinformationen an Integration Broker gesendet. Zur weiteren Behebung des Problems überprüfen Sie die Protokolle auf dem Integration Broker-Host unter %programdata%/VMware/HorizonIntegrationBroker.

  2. Verwenden Sie einen Browser, um eine Liste aller von Citrix veröffentlichten Ressourcen in der Serverfarm anzuzeigen.
    1. Geben Sie in einem Browser eine URL ein, etwa eine der folgenden, und ersetzen Sie dabei die Platzhalter durch die konkreten Informationen.
      • Citrix Server Farm 7.x

        Anzeigen einer Liste aller Anwendungen:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/applications?computerName=XenAppServerHostname&xenappversion=Version7x

        Anzeige einer Liste aller Bereitstellungsgruppen:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/deliveryGroups?computerName=XenAppServerHostname&xenappversion=Version7x

      • Citrix Server Farm 6.5

        https://IB-Hostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/applications?computerName=XenAppServer-Hostname&xenappversion=Version65orLater

      • Citrix Server Farm 5.5 oder 6.0

        https://IB-Hostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/applications?computerName=XenAppServer-Hostname&xenappversion=Legacy

    2. Überprüfen Sie den Inhalt der Webseite und bei Bedarf die Integration Broker-Protokolle.
      Wenn Integration Broker ordnungsgemäß konfiguriert ist, wird auf der Seite eine Liste aller Ressourcen in der Citrix-Serverfarm angezeigt.

      Wenn auf einer Webseite keine Liste mit Ressourcen erscheint, werden Protokollinformationen an Integration Broker gesendet. Zur weiteren Behebung des Problems überprüfen Sie die Protokolle auf dem Integration Broker-Host unter %programdata%/VMware/HorizonIntegrationBroker.

  3. Verwenden Sie einen Browser, um die Berechtigungen für einzelne von Citrix veröffentlichte Ressourcen zu prüfen.
    1. Geben Sie in einem Browser eine URL ein, etwa eine der folgenden, und ersetzen Sie dabei die Platzhalter durch die konkreten Informationen.
      Ersetzen Sie den Platzhalter Anwendungsname durch den Namen der gewünschten Anwendung.
      • Citrix Server Farm 7.x

        Prüfen einer Anwendung:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/entitlements?computerName=XenAppServerHostname&xenappversion=Version7x&appName=ApplicationName

        Prüfen einer Bereitstellungsgruppe:

        https://IBhostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/deliveryGroup/entitlements?computerName=XenAppServerHostname&xenappversion=Version7x&deliveryGroupName=deliveryGroupName

      • Citrix Server Farm 6.5

        https://IB-Hostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/entitlements?computerName=XenAppServer-Hostname&xenappversion=Version65orLater&appName=Anwendungsname

      • Citrix Server Farm 5.5 oder 6.0

        https://IB-Hostname/IB/API/RestServiceImpl.svc/hznxenapp/admin/entitlements?computerName=XenAppServer-Hostname&xenappversion=Legacy&appName=Anwendungsname

    2. Überprüfen Sie den Inhalt der Webseite und bei Bedarf die Integration Broker-Protokolle.
      Wenn Integration Broker ordnungsgemäß konfiguriert ist, wird auf der Seite eine Liste aller Berechtigungen für die von Ihnen angegebene Anwendung oder Bereitstellungsgruppe angezeigt.

      Wenn auf einer Webseite keine Liste mit Berechtigungen erscheint, werden Protokollinformationen an Integration Broker gesendet. Zur weiteren Behebung des Problems überprüfen Sie die Protokolle auf dem Integration Broker-Host unter %programdata%/VMware/HorizonIntegrationBroker.