Das Upgrade schlägt mit dem Fehler „Aktualisierung der Zertifikatsauthentifizierung erforderlich“ fehl.

Problem

Wenn Sie versuchen, ein Upgrade auf VMware Identity Manager 3.3.4 durchzuführen, wird die folgende Fehlermeldung angezeigt und das Upgrade wird abgebrochen.

Aktualisierung der Zertifikatsauthentifizierung für Mandant <tenantName> vor dem Upgrade erforderlich. Fehler bei der Prüfung vor dem Update, Upgrade wird abgebrochen.

Ursache

Dieses Problem tritt auf, wenn Zertifikate für den CertificateAuthAdapter zuletzt vor Version 3.0 hinzugefügt oder aktualisiert wurden.

Lösung

  1. Melden Sie sich bei der VMware Identity Manager-Konsole an.
  2. Navigieren Sie zu Identitäts- und Zugriffsmanagement > Setup.
  3. Klicken Sie auf der Seite Konnektoren auf den Link in der Spalte Worker.
  4. Klicken Sie auf die Registerkarte Authentifizierungsadapter und dann auf CertificateAuthAdapter.
  5. Klicken Sie im Abschnitt Hochgeladene CA-Zertifikate auf das rote X, um das Zertifikat zu entfernen.
  6. Klicken Sie auf Speichern.
  7. Klicken Sie im Abschnitt Root- und Zwischen-CA-Zertifikate auf Datei auswählen, um das Zertifikat erneut hinzuzufügen.
  8. Klicken Sie auf Speichern.
  9. Kehren Sie zur Konsole der virtuellen Appliance zurück und führen Sie die Upgrade-Befehle erneut aus.