Bei der Datendefinition werden Eigenschaften, Metriken, Richtlinien oder von Adaptern bereitgestellte Daten zu einer Ansicht hinzugefügt. Hierbei handelt es sich um die Elemente, nach denen vRealize Operations Cloud die Informationen für die Ansicht erfasst, berechnet und darstellt.

Klicken Sie im Menü auf Dashboards und klicken Sie dann im linken Fensterbereich auf Ansichten, um einer Ansicht Daten hinzuzufügen. Klicken Sie die Option Hinzufügen an. Klicken Sie im Arbeitsbereich links auf Daten. Um eine Ansicht zu erstellen, führen Sie die zuvor beschriebenen erforderlichen Schritte durch.

Informationen zum Hinzufügen von Daten zu einer Ansicht

Wenn Sie mehrere Betreffe ausgewählt haben, geben Sie den Betreff an, für den Sie die Daten hinzugefügt haben. Doppelklicken Sie im linken Bereich auf die Daten aus der Struktur, um sie zur Ansicht hinzuzufügen. Die Daten, die für jeden Betreff zum Hinzufügen verfügbar sind, unterscheiden sich möglicherweise.

Konfigurieren der Datentransformation

Die Datenkonfigurationsoptionen hängen von der jeweiligen Ansicht und dem ausgewählten Datentyp ab. Die meisten Optionen sind für alle Ansichten verfügbar.

Tabelle 1. Datenkonfigurationsoptionen
Konfigurationsoption Beschreibung
Metrikname

Standardmetrikname.

Verfügbar für alle Ansichten.

Metrikbezeichnung

Anpassbare Beschriftung, wie sie in der Ansicht oder im Bericht angezeigt wird.

Verfügbar für alle Ansichten.

Einheiten

Hängt von der hinzugefügten Metrik oder Eigenschaft ab. Sie können auswählen, in welcher Einheit die Werte angezeigt werden sollen. Für CPU|Bedarf(MHz) im Dropdown-Menü Einheiten können Sie den Wert in Hz, KHz oder GHz ändern. Wenn Sie Auto auswählen, wird die Skalierung auf eine sinnvolle Einheit festgelegt.

Verfügbar für alle Ansichten.

Sortierreihenfolge

Sortiert die Werte in aufsteigender oder absteigender Reihenfolge.

Verfügbar für die Ansichten „Liste“ und „Übersicht“.

Umsetzung
Bestimmt, welche Berechnungsmethode auf die Rohdaten angewendet wird. Sie können den Informationstyp auswählen:
  • Mindestwert. Der Mindestwert der Metrik im ausgewählten Zeitbereich.
  • Maximalwert. Der Maximalwert der Metrik im ausgewählten Zeitbereich.
  • Durchschnitt. Der Durchschnitt aller metrischen Werte im ausgewählten Zeitbereich.
  • Summe. Die Summe der metrischen Werte im ausgewählten Zeitbereich.
  • Erste. Der erste metrische Wert für den ausgewählten Zeitbereich.
  • Letzte. Der letzte Wert einer Metrik innerhalb des ausgewählten Zeitbereichs.
  • Aktuell. Der letzte verfügbare Wert einer Metrik, wenn dieser nicht vor Abschluss der letzten fünf Erfassungszyklen aktualisiert wurde, andernfalls null.
  • Standardabweichung. Die Standardabweichung der metrischen Werte.
  • Metrische Korrelation. Zeigt den Wert an, wenn sich eine andere Metrik beim Mindest- oder Maximalwert befindet. Zeigt beispielsweise den Wert für memory.usage an, wenn sich cpu.usage beim Maximalwert befindet.
  • Prognose. Führt eine regressive Analyse durch und prognostiziert zukünftige Werte. Zeigt den letzten Metrikwert des ausgewählten Bereichs an.
  • Perzentil. Berechnet das festgelegte Perzentil für den Datumsbereich. Beispielsweise können Sie das 95. Perzentil, das 99. Perzentil usw. anzeigen.
  • Ausdruck. Ermöglicht Ihnen die Konstruktion eines mathematischen Ausdrucks über vorhandene Transformationen, unter Verwendung der Operationszeichen Minus, Plus, Multiplikation, Division, unäres Minus, unäres Plus und runde Klammern. Beispiel: Summe/((max + min)/2). Sie können die Operanden einiger vorhandener Transformationen, wie z. B. max, min, avg, sum, first, last, current, verwenden. Sie können standard deviation, forecast, metric correlation, and percentile nicht verwenden.

Verfügbar für alle Ansichten mit Ausnahme von „Trend“.

  • Zeitstempel: Sie können zwischen Absolute Timestamp oder Relative Timestamp auswählen.
  • Wenn dieser auf eine numerische Metrik/Eigenschaft angewendet wird, die mit einer Zeiteinheitendefinition festgelegt wurde, wird der tatsächliche Wert in einen lesbaren Zeitstempel umgewandelt. Der Metrikwert wird auf eine Stunde gerundet.

    Gilt für absoluten Zeitstempel.

  • In den übrigen Fällen wird ein Zeitstempel angezeigt, wenn Metriken und Eigenschaften hinzugefügt oder geändert werden. In diesem Fall ist das Verhalten identisch mit der Zeitstempeloption, die für eine Nicht-Zeitstempel-Transformation ausgewählt wurde.

    Gilt für absoluten Zeitstempel und relativen Zeitstempel.

    Verfügbar für die Listenansicht sowie für die min., max., aktuelle, erste und letzte Transformation.

Bereiche für die Metrik-Farbgebung Sie können Farben mit Metriken verknüpfen, indem Sie einen Prozentsatz, einen Bereich oder einen bestimmten Zustand angeben. Beispielsweise können Sie „Ausgeschaltet“ in das Feld Rote Bindung eingeben, wenn Sie die virtuelle Maschine als ein Objekt auswählen. Sie können die Farben nur für Ansichten und nicht für CSV- oder die PDF-Formate festlegen.
Datenserie

Sie können auswählen, ob historische Daten, der Trend historischer Daten und Prognosen für die Zukunft in die Berechnungen der Ansicht „Trend“ einbezogen werden.

Verfügbar für die Ansicht "Trend".

Serienzusammenfassung

Das Zeitintervall, in dem die Daten zusammengefasst werden. Sie können eine der verfügbaren Kombinationen auswählen. Wenn Sie beispielsweise Sum als Transformation und 5 Minuten als Zusammenfassungsintervall auswählen, dann wählt das System 5-Minuten-Intervallwerte und fügt sie hinzu.

Diese Option gilt für die Konfigurationsoption „Transformation“.

Verfügbar für alle Ansichten.

Schwellenwert-Zeilen Sie können einen Schwellenwert für eine einzelne Metrik festlegen:
  • Keine. Sie haben keinen Schwellenwert festgelegt.
  • Nach Symptomdefinition. Sie können einen Schwellenwert basierend auf einer Symptomdefinition festlegen.
  • Benutzerdefiniert. Sie können den Schwellenwert als Warnung, Kritisch oder Unverzüglich festlegen. Diese Optionen stehen nur für die Option Benutzerdefiniert zur Verfügung.

Verfügbar für die Ansicht „Trend“.

Zeiteinstellungen konfigurieren

Verwenden Sie die Zeiteinstellung, um das Zeitintervall für die Datentransformation auszuwählen. Diese Optionen sind für alle Ansichtstypen verfügbar, außer für „Bild“.

Sie können einen Zeitbereich für einen vergangenen Zeitraum oder ein zukünftiges Datum für das Ende des Zeitbereichs einstellen. Wenn Sie ein zukünftiges Enddatum wählen und keine Daten verfügbar sind, werden Datenprognosen angezeigt.

Tabelle 2. Optionen für Zeiteinstellungen
Konfigurationsoption Beschreibung
Zeitbereichsmodus

Im Basismodus können Sie Datumsbereiche wählen.

Im erweiterten Modus können Sie jegliche Kombinationen relativer oder spezifischer Start- und Enddaten wählen.

Relativer Datumsbereich

Wählen Sie einen relativen Datumsbereich der Datentransformation.

Verfügbar im Basismodus.

Spezifischer Datumsbereich

Wählen Sie einen spezifischen Datumsbereich der Datentransformation.

Verfügbar im Basismodus.

Absoluter Datenbereich

Wählen Sie einen Daten- oder Zeitbereich aus, um Daten für eine Zeiteinheit, z. B. einen ganzen Monat oder eine Woche, anzuzeigen. Sie können beispielsweise einen Bericht am Dritten jedes Monats für den vorherigen Monat ausführen. Es werden die Daten vom ersten bis zum letzten Tag des vorherigen Monats, im Gegensatz zum dritten Tag des vorherigen Monats bis zum dritten Tag des aktuellen Monats.

Diese Einheiten stehen zur Verfügung: Stunden, Tage, Wochen, Monate und Jahre.

Die Ländereinstellungen des Systems bestimmen den Anfang und das Ende der Einheit. So beginnen die Wochen in den meisten europäischen Ländern am Montag, während sie in den USA am Sonntag beginnen.

Verfügbar im Basismodus.

Relatives Startdatum

Wählen Sie ein relatives Startdatum der Datentransformation.

Verfügbar im fortgeschrittenen Modus.

Relatives Enddatum

Wählen Sie ein relatives Enddatum der Datentransformation.

Verfügbar im fortgeschrittenen Modus.

Spezifisches Startdatum

Wählen Sie ein spezifisches Startdatum der Datentransformation.

Verfügbar im fortgeschrittenen Modus.

Spezifisches Enddatum

Wählen Sie ein spezifisches Enddatum der Datentransformation.

Verfügbar im fortgeschrittenen Modus.

Aktuell ausgewählter Datenbereich

Zeigt den ausgewählten Datums- oder Zeitbereich an. Beispiel: Wenn Sie einen bestimmten Datumsbereich vom 01.05.2016 bis zum 18.05.2016 auswählen, werden die folgenden Informationen angezeigt: May 1, 2016 12:00:00 AM to May 18, 2016 11:55:00 PM.

Daten herunterbrechen

Sie können Daten in Listenansichten herunterbrechen, indem Sie Intervall- oder Instanzspalten aus dem Reiter Gruppieren nach hinzuzufügen.

Tabelle 3. Gruppieren nach Optionen
Option Beschreibung
Fügen Sie eine Intervallspalte hinzu (siehe Daten für Spalteneinstellungen)

Wählen Sie diese Option, um die nach gewählten Ressourcen in Zeitintervalle heruntergebrochenen Daten anzuzeigen.

Wählen Sie im Reiter Daten Nach Intervallen herunterbrechen, um die Spalte zu konfigurieren. Sie können eine Bezeichnung eintragen und ein herunterzubrechendes Intervall für den Zeitbereich auswählen.

Fügen Sie eine Instanzspalte hinzu (siehe Daten für Spalteneinstellungen)

Wählen Sie diese Option, um die Daten für alle Instanzen der gewählten Ressourcen anzuzeigen.

Wählen Sie im Reiter Daten Instanzname, um die Spalte zu konfigurieren. Sie können eine Bezeichnung eingeben und eine metrische Gruppe auswählen, um alle Instanzen dieser Gruppe herunterzubrechen. Wählen Sie aggregierte Metrik für Nicht-Instanzen anzeigen ab, um nur die getrennten Instanzen anzuzeigen. Wählen Sie Nur den Instanznamen anzeigen ab, um den Namen der metrischen Gruppe und Instanznamen in der Instanzspalte anzuzeigen.

Sie können z. B. eine Anzeige erstellen, um die CPU-Verwendung zu visualisieren, indem Sie die MetrikCPU:0|Usage wählen. Wenn Sie eine Instanzspalte hinzufügen, zeigt die Spalte „CPU:0|Usage“ die Verwendung aller CPU-Instanzen in getrennten Zeilen (0, 1 usw.). Um Verwechselungen zu vermeiden, können Sie die MetrikbezeichnungCPU:0|Usage nach Usage ändern.

Hinzufügen eines Filters

Die Filteroption ermöglicht Ihnen, zusätzliche Kriterien hinzuzufügen, wenn in der Ansicht zu viele Informationen angezeigt werden. Angenommen, eine Liste enthält Informationen zum Systemzustand virtueller Maschinen. Über die Registerkarte Filter fügen Sie eine Metrik für ein Risiko kleiner 50 % hinzu. Dann zeigt die Ansicht den Systemzustand aller virtuellen Maschinen mit einem Risiko unter 50 % an.

Um Filter zu einer Ansicht hinzuzufügen, wählen Sie im linken Bereich Inhalt > Ansichten aus. Klicken Sie auf der Ansichten-Symbolleiste auf das Pluszeichen, um eine Ansicht hinzuzufügen, oder auf den Stift, um die ausgewählte Ansicht zu bearbeiten. Klicken Sie im Arbeitsbereich links auf Daten und klicken Sie dann im Hauptbereich auf die Registerkarte Filter. Um eine Ansicht zu erstellen, führen Sie die zuvor beschriebenen erforderlichen Schritte durch.

Jeder Betreff verfügt über ein separates Filterfeld. Bei den Themen Warnungs-Rollup, Warnung und Symptom können nicht alle vorhandenen Metriken zum Filtern verwendet werden.

Tabelle 4. Optionen zum Hinzufügen von Filtern
Option Beschreibung
Hinzufügen Fügt ein weiteres Kriterium zum Kriteriensatz hinzu. Der Filter gibt Ergebnisse zurück, die allen angegebenen Kriterien entsprechen.
Weiteren Kriteriensatz hinzufügen Fügt einen weiteren Kriteriensatz hinzu. Der Filter gibt Ergebnisse zurück, die dem einem oder anderen Kriteriensatz entsprechen.

Hinzufügen einer Zusammenfassungszeile oder -spalte zu einer Ansicht

Die Zusammenfassungsoption ist nur für die Ansichten „Liste“ und „Übersicht“ verfügbar. Für die Zusammenfassungsansichten ist sie obligatorisch. Sie können mehr als eine Zusammenfassungszeile oder -spalte hinzufügen und jede einzelne konfigurieren, um verschiedene Zusammenfassungen anzuzeigen. Wählen Sie im Bereich der Übersichtskonfiguration die Zusammenfassungsmethode und die Daten aus, die in die Berechnung eingeschlossen oder aus ihr ausgeschlossen werden sollen.

Um eine Zusammenfassungszeile oder -spalte zu einer Ansicht hinzuzufügen, wählen Sie im linken Bereich Inhalt > Ansichten aus. Klicken Sie auf der Ansichten-Symbolleiste auf das Pluszeichen, um eine Ansicht hinzuzufügen, oder auf den Stift, um die ausgewählte Ansicht zu bearbeiten. Klicken Sie im Arbeitsbereich links auf Daten und dann im Hauptbereich auf die Registerkarte Übersicht. Um eine Ansicht zu erstellen, führen Sie die zuvor beschriebenen erforderlichen Schritte durch.

Die Zusammenfassungszeile zeigt für die Ansicht „Liste“ zusammenfassende Informationen nach bestimmten Betreffen an.

Die Zusammenfassungsspalte zeigt für die Ansicht „Übersicht“ zusammenfassende Informationen nach den Elementen an, die auf der Registerkarte Daten bereitgestellt werden.