UMDS muss eine Version aufweisen, die mit dem Update Manager-Server kompatibel ist.

Update Manager kann zusammen mit einer bestimmten UMDS-Version verwendet werden, falls die Metadaten und die Struktur des Patch-Speichers, der von UMDS exportiert wird, kompatibel mit Update Manager ist und die Daten vom Update Manager-Server importiert und verwendet werden können.

Da Update Manager 5.x das Anwenden von Patches auf Gastbetriebssysteme nicht unterstützt und vCenter Server 5.5 ESX/ESXi 3.5-Hostvorgänge nicht unterstützt, lädt UMDS 5.5 keine Patches für Gastbetriebssysteme und ESX/ESXi 3.5-Hosts herunter. UMDS 5.5 ist mit Update Manager 5.0, Update Manager 5.1, Update Manager 5.5 und den entsprechenden Update-Versionen kompatibel und funktionsfähig.