Wenn Sie versuchen, Netzwerke auf einem vSphere Distributed Switch auf einem Host hinzuzufügen oder zu konfigurieren, wird für den Vorgang ein Rollback durchgeführt und die Verbindung zwischen Host und vCenter Server wird getrennt.
Problem
In vSphere 5.1 oder höher führt ein Versuch, einen Netzwerkkonfigurationsvorgang auf einem vSphere Distributed Switch auf einem Host durchzuführen, z. B. einen VM-Adapter oder eine Portgruppe zu erstellen, dazu, dass die Verbindung zwischen Host und vCenter Server getrennt und die Fehlermeldung Für die Transaktion wurde auf dem Host ein Rollback durchgeführt angezeigt wird.
Ursache
Bei hoher Belastung des Hosts, d. h., wenn viele gleichzeitige Netzwerkvorgänge sich begrenzte Ressourcen teilen müssen, überschreitet die Ausführungsdauer einiger der Vorgänge möglicherweise das Standardzeitlimit für das Rollback von Netzwerkkonfigurationsvorgängen auf dem Distributed Switch. Infolgedessen wird für diese Vorgänge ein Rollback durchgeführt.
Solch eine Bedingung kann beispielsweise eintreten, wenn Sie einen VMkernel-Adapter auf einem Host erstellen, der eine große Zahl von Switch-Ports oder virtuellen Adaptern aufweist, die alle Systemressourcen auf dem Host verbrauchen.
Das Standardzeitlimit für das Rollback eines Vorgangs beträgt 30 Sekunden.
Lösung
- Verwenden Sie den vSphere Web Client, um die Zeitüberschreitung für das Rollback auf dem vCenter Server zu erhöhen.
Falls dasselbe Problem erneut auftritt, erhöhen Sie die Zeitüberschreitung für das Rollback schrittweise um jeweils 60 Sekunden, bis die Zeit ausreicht, um den Vorgang erfolgreich auszuführen.
- Erweitern Sie auf der Registerkarte Konfigurieren einer vCenter Server-Instanz die Option Einstellungen.
- Wählen Sie Erweiterte Einstellungen aus und klicken Sie auf Bearbeiten.
- Wenn die Eigenschaft nicht existiert, fügen Sie den Parameter config.vpxd.network.rollbackTimeout zu den Einstellungen hinzu.
- Geben Sie für den Parameter config.vpxd.network.rollbackTimeout einen neuen Wert (in Sekunden) ein.
- Klicken Sie auf OK.
- Starten Sie das vCenter Server-System neu, um die Änderungen anzuwenden.
- Erhöhen Sie die Zeitüberschreitung für das Rollback durch Bearbeiten der vpxd.cfg-Konfigurationsdatei.
Falls dasselbe Problem erneut auftritt, erhöhen Sie die Zeitüberschreitung für das Rollback schrittweise um jeweils 60 Sekunden, bis die Zeit ausreicht, um den Vorgang erfolgreich auszuführen.
- Navigieren Sie auf einer vCenter Server-Instanz in das Verzeichnis, das die vpxd.cfg-Konfigurationsdatei enthält.
- Navigieren Sie in einem Windows Server-Betriebssystem zu vCenter Server-Stammverzeichnis\Application Data\VMware\VMware VirtualCenter.
- Navigieren Sie auf der vCenter Server-Appliance zu /etc/vmware-vpx.
- Öffnen Sie die Datei vpxd.cfg zur Bearbeitung.
- Erhöhen Sie im Abschnitt
<network>
für das Element <rollbackTimeout>
die Zeitüberschreitung.
<config>
<vpxd>
<network>
<rollbackTimeout>60</rollbackTimeout>
</network>
</vpxd>
</config>
- Speichern und schließen Sie die Datei.
- Starten Sie das vCenter Server-System neu, um die Änderungen anzuwenden.