In einigen Situationen tritt möglicherweise ein Problem bei der vSphere Auto Deploy-Datenbank auf. Die effizienteste Wiederherstellungsoption besteht darin, die vorhandene Datenbankdatei durch die letzte Sicherung zu ersetzen.
Problem
Wenn Sie vSphere Auto Deploy zum Bereitstellen der
ESXi-Hosts in Ihrer Umgebung verwenden, tritt möglicherweise ein Problem bei der vSphere Auto Deploy-Datenbank auf.
Wichtig: Dieses Problem tritt nur selten auf. Führen Sie alle anderen Fehlerbehebungsstrategien für vSphere Auto Deploy aus, bevor Sie die aktuelle Datenbankdatei ersetzen. Regeln und Verknüpfungen, die Sie seit der ausgewählten Sicherung erstellt haben, gehen verloren.
Ursache
Dieses Problem tritt nur bei Hosts auf, die mit vSphere Auto Deploy bereitgestellt werden.
Lösung
- Beenden Sie den vSphere Auto Deploy-Server-Dienst.
- Suchen Sie das vSphere Auto Deploy-Protokoll, indem Sie zur vSphere Auto Deploy-Seite im vSphere Web Client navigieren.
- Durchsuchen Sie die Protokolle nach der folgenden Meldung:
DatabaseError: database disk image is malformed.
Wenn Sie diese Meldung finden, ersetzen Sie die vorhandene Datenbank durch die letzte Sicherung.
- Navigieren Sie zum vSphere Auto Deploy-Datenverzeichnis.
Betriebssystem |
Dateispeicherort |
vCenter Server Appliance |
/var/lib/rbd |
Microsoft Windows |
%VMWARE_DATA_DIR%\autodeploy\Data |
Das Verzeichnis enthält eine Datei mit dem Namen
db und Sicherungsdateien mit den Namen
db-
jjj-
mm-
tt.
- Benennen Sie die aktuelle db-Datei um.
VMware Support wird Sie möglicherweise nach dieser Datei fragen, wenn Sie Assistenz anfordern.
- Benennen Sie die letzte Sicherung in db um.
- Starten Sie den vSphere Auto Deploy-Server-Dienst neu.
- Falls die Meldung weiterhin im Protokoll angezeigt wird, wiederholen Sie die Schritte, um die nächste letzte Sicherung zu verwenden, bis bei Verwendung von vSphere Auto Deploy keine Datenbankfehler mehr auftreten.