Der vSphere HA-Agent auf einem Host befindet sich für eine Minute oder länger im Zustand „Initialisierungsfehler“. Der Benutzer muss eingreifen, um diesen Zustand zu beheben.

Problem

vSphere HA meldet, dass sich ein Agent im Zustand „Initialisierungsfehler“ befindet, wenn der letzte Versuch, vSphere HA für den Host zu konfigurieren, fehlgeschlagen ist. vSphere HA überwacht die virtuellen Maschinen auf einem solchen Host nicht und startet sie nach einem Ausfall möglicherweise nicht.

Ursache

In der Regel deutet dieser Zustand darauf hin, dass vCenter Server keine Verbindung zum Host herstellten konnte, als der vSphere HA-Agent auf dem Host installiert oder konfiguriert wurde. Diese Bedingung könnte auch darauf hindeuten, dass Installation und Konfiguration zwar abgeschlossen sind, der Agent aber nicht innerhalb der festgelegten Zeit zu einem primären Host oder sekundären Host wurde. Seltener ist der Zustand ein Hinweis darauf, dass nicht genügend Speicherplatz auf dem lokalen Datenspeicher des Hosts vorhanden ist, um den Agenten zu installieren, oder es zu wenig nicht reservierte Arbeitsspeicherressourcen auf dem Host für den Agentenressourcenpool gibt. Schließlich schlägt die Konfiguration für ESXi 5.x-Hosts fehl, wenn durch die vorherige Installation einer anderen Komponente ein Neustart erforderlich war, der Neustart jedoch noch nicht erfolgt ist.

Lösung

Wenn eine Aufgabe zum Konfigurieren von HA fehlschlägt, wird die Fehlerursache gemeldet.
Fehlerursache Aktion
Hostkommunikationsfehler Beheben Sie alle Kommunikationsprobleme mit dem Host und wiederholen Sie den Konfigurationsvorgang.
Zeitüberschreitungsfehler Mögliche Ursachen sind: Der Host ist während der Konfigurationsaufgabe ausgefallen, der Agent konnte nach der Installation nicht gestartet werden oder der Agent konnte sich nach dem Start nicht initialisieren. Stellen Sie sicher, dass vCenter Server mit dem Host kommunizieren kann. Wenn dies der Fall ist, finden Sie mögliche Lösungen in Der vSphere HA-Agent befindet sich im Zustand „HA-Agent nicht erreichbar“ oder Der vSphere HA-Agent befindet sich im Zustand „Nicht initialisiert“.
Mangel an Ressourcen Geben Sie ungefähr 75 MB Festplattenspeicher frei. Wenn der Fehler auf unzureichenden nicht reservierten Arbeitsspeicher zurückzuführen ist, geben Sie auf dem Host Arbeitsspeicher frei, indem Sie entweder virtuelle Maschinen auf einen anderen Host verlagern oder deren Reservierungen reduzieren. In beiden Fällen wiederholen Sie die vSphere HA-Konfigurationsaufgabe, nachdem Sie das Problem behoben haben.
Neustart ausstehend Wenn die Installation eines Hosts der Version 5.0 oder höher fehlschlägt, weil ein Neustart noch aussteht, starten Sie den Host neu und wiederholen Sie die vSphere HA-Konfigurationsaufgabe.