Wenn ein Datenspeicher im VMware Host Client ungemountet wird, bleibt dieser intakt, er wird jedoch nicht mehr in der Bestandsliste des verwalteten Hosts angezeigt. Der Datenspeicher wird weiterhin auf anderen Hosts angezeigt, auf denen er gemountet bleibt.
Voraussetzungen
- Es dürfen sich keine virtuelle Maschinen im Datenspeicher befinden.
- Speicher-DRS verwaltet den Datenspeicher nicht.
- Storage I/O Control ist für diesen Datenspeicher deaktiviert.
Prozedur
- Klicken Sie in der VMware Host Client-Bestandsliste auf Speicher und anschließend auf Datenspeicher.
- Klicken Sie in der Liste mit der rechten Maustaste auf den Datenspeicher, der unmountet werden soll, und klicken Sie auf Unmounten.
- Bestätigen Sie, dass Sie den Datenspeicher unmounten möchten.
Das Unmounten oder Entfernen eines Datenspeichers schlägt fehl
Wenn Sie versuchen, ein Unmounten oder Entfernen eines Datenspeichers durchzuführen, schlägt der Vorgang fehl.
Problem
Das Unmounten oder Entfernen eines Datenspeichers schlägt fehl, wenn im Datenspeicher geöffnete Dateien vorhanden sind. Für diese Benutzervorgänge schließt der vSphere HA-Agent alle Dateien, die er geöffnet hat, beispielsweise die Taktsignal-Dateien. Falls der Agent nicht von vCenter Server erreicht werden kann oder der Agent ausstehende E/A-Vorgänge nicht auf die Festplatte schreiben kann, um die Dateien zu schließen, wird der Fehler Der vSphere HA-Agent auf Host '{hostName}' konnte die Dateiaktivitäten auf dem Datenspeicher '{dsName}' nicht stilllegen ausgelöst.
Ursache
Wenn der Datenspeicher, für den ein Unmounten durchgeführt oder der entfernt werden soll, für Taktsignale verwendet wird, schließt vCenter Server ihn als Taktsignal-Datenspeicher aus und wählt dafür einen neuen Datenspeicher aus. Allerdings empfängt der Agent nicht die aktualisierten Taktsignal-Datenspeicher, wenn er nicht erreichbar ist. Dies ist der Fall, wenn der Host isoliert ist oder sich in einer Netzwerkpartition befindet. In diesen Fällen werden die Taktsignal-Dateien nicht geschlossen und der Benutzervorgang schlägt fehl. Der Vorgang kann auch fehlschlagen, wenn der Datenspeicher aufgrund von Speicherausfällen, z. B. „Keine Pfade verfügbar“, nicht zugänglich ist.
Lösung
Stellen Sie sicher, dass der Datenspeicher zugänglich ist und die betreffenden Hosts erreichbar sind.