Der vSphere HA-Agent auf einem Host befindet sich für eine Minute oder länger im Zustand „HA-Agent nicht erreichbar“. Der Benutzer muss möglicherweise eingreifen, um diesen Zustand zu beheben.

Problem

vSphere HA meldet, dass sich ein Agent im Zustand „Agent nicht erreichbar“ befindet, wenn der Agent für den Host nicht vom primären Host oder vCenter Server kontaktiert werden kann. Folglich ist vSphere HA nicht in der Lage, die virtuellen Maschinen auf dem Host zu überwachen, und kann möglicherweise diese nach einem Ausfall nicht neu starten.

Ursache

Es gibt mehrere Gründe, weshalb sich ein vSphere HA-Agent im Zustand „Agent nicht erreichbar“ befinden kann. In der Regel bedeutet dieser Zustand, dass ein Netzwerkproblem vCenter Server oder den primären Host daran hindert, den Agent auf dem Host zu kontaktieren, oder dass alle Hosts im Cluster ausgefallen sind. Dieser Zustand kann auch auf den eher unwahrscheinlichen Fall hindeuten, dass vSphere HA auf dem Cluster deaktiviert und anschließend wieder aktiviert wurde, während vCenter Server nicht mit dem vSphere HA-Agenten auf dem Host kommunizieren konnte, oder dass der ESXi-Host-Agent auf dem Host ausgefallen ist und der Watchdog-Prozess ihn nicht neu starten konnte. In jedem dieser Fälle wird kein Failover-Ereignis ausgelöst, wenn ein Host in den Zustand „Unerreichbar“ übergeht.

Lösung

Überprüfen Sie, ob vCenter Server meldet, dass der Host nicht reagiert. Ist dies der Fall, liegt ein Netzwerkproblem, der Ausfall eines ESXi-Host-Agenten oder der vollständige Ausfall eines Clusters vor. Nach Behebung des Problems sollte vSphere HA ordnungsgemäß funktionieren. Ist dies nicht der Fall, konfigurieren Sie vSphere HA auf dem Host neu. Wenn vCenter Server meldet, dass die Hosts antworten, der Zustand eines Hosts jedoch „Agent nicht erreichbar“ ist, müssen Sie ebenfalls vSphere HA auf dem betreffenden Host neu konfigurieren.