Eine Fehlermeldung bezüglich des Verwaltungsagenten wird angezeigt, wenn Sie auf der Seite „Status aktualisieren“ der vRealize Automation-Appliance-Verwaltungskonsole auf Updates installieren klicken.

Problem

Upgrade-Prozess ist fehlgeschlagen. Folgende Fehlermeldung wird angezeigt: Management-Agent auf Knoten x konnte nicht aktualisiert werden. In manchen Fällen werden in dieser Meldung mehrere Knoten aufgelistet.

Ursache

Für dieses Problem gibt es zahlreiche Ursachen. In der Fehlermeldung wird nur die Knoten-ID der betroffenen Maschine angegeben. Weitere Informationen finden Sie in der Datei All.log für den Management-Agent auf der Maschine, auf der der Befehl fehlgeschlagen ist.

Führen Sie diese Aufgaben entsprechend der bei Ihnen vorliegenden Situation auf den betroffenen Knoten durch:

Lösung

  • Wenn der Management-Agent-Dienst nicht ausgeführt wird, starten Sie den Dienst und starten Sie das Upgrade auf der virtuellen Appliance neu.
  • Wenn der Management-Agent-Dienst ausgeführt wird und ein Upgrade des Management-Agents durchgeführt wird, starten Sie das Upgrade auf der virtuellen Appliance neu.
  • Wenn der Management-Agent-Dienst ausgeführt wird, jedoch kein Upgrade des Management-Agents durchgeführt wird, führen Sie ein manuelles Upgrade durch.
    1. Öffnen Sie einen Browser und wechseln Sie zur Seite „vRealize Automation-IaaS-Installation“ auf der vRealize Automation-Appliance unter https:// va-hostname.domain.name:5480/install.
    2. Laden Sie das Installationsprogramm für den Management-Agent herunter und führen Sie es aus.
    3. Starten Sie die Management-Agent-Maschine neu.
    4. Starten Sie das Upgrade auf der virtuellen Appliance neu.