Sie können kein AWS-Konto hinzufügen, das Sie mithilfe von vRealize Business for Cloud nachverfolgen und analysieren möchten.

Problem

Beim Versuch, ein AWS-Konto hinzuzufügen, wird auf der Registerkarte Administration im Systemstatus ein AWS-Datenerfassungsfehler angezeigt. Überprüfen Sie die Datei itfm-server.log auf weitere Details zu dem Fehler.

Ursache

Dieses Problem kann folgende Ursachen haben.
  • Beim Hinzufügen eines Kontos sind die zahlenden Konten nicht als primäre Konten gekennzeichnet.
  • Die AWS-CSV-Datei ist zu groß für den verfügbaren Speicher der virtuellen vRealize Business for Cloud-Appliance.
  • Für zahlende Konten haben Sie den detaillierten Abrechnungsbericht nicht aktiviert.
  • Die Konto-ID enthält Sonderzeichen oder -buchstaben, oder die Länge der Konto-ID überschreitet 12 Zeichen.
  • Der Abrechnungsbericht ist im S3-Bucket nicht verfügbar.
  • Sie verfügen nicht über die Berechtigung zum Hinzufügen des Kontos.

Lösung

  • Führen Sie zur Behebung dieses Problems den entsprechenden Schritt der folgenden Lösungsmöglichkeiten aus.
    • Stellen Sie sicher, dass das zahlende Konto beim Hinzufügen eines Kontos als primäres Konto ausgewählt ist.
    • Aktivieren Sie für die zahlenden Konten die Option für die detaillierte Abrechnung.
    • Vergewissern Sie sich, dass die Konto-ID keine Sonderzeichen enthält.
    • Stellen Sie sicher, dass mindestens ein im S3-Bucket vorhandener Abrechnungsbericht der folgenden Benennungskonvention entspricht: 123456789012-aws-billing-detailed-line-items-with-resources-and-tags-yyyy-mm.csv.zip. Dabei ist 123456789012 die Konto-ID, yyyy ist das Jahr und mm ist der Monat.
    • Stellen Sie für ein zahlendes Konto sicher, dass der AWS-Benutzer über die erforderlichen Berechtigungen wie z. B. s3:Get*, s3:List* und ec2:Describe* verfügt.

      Vergewissern Sie sich für ein nicht zahlendes Konto, dass der AWS-Benutzer über die Berechtigung ec2:Describe* verfügt.