Eine falsche Konfiguration kann den vRealize Log Insight-Agents daran hindern, Protokolle an den vRealize Log Insight-Server weiterzuleiten. Wenn ein Flatfile-Erfassungskanal nicht korrekt konfiguriert ist, sehen Sie möglicherweise Meldungen wie „Für den Kanal 'CHANNEL_NAME' wurden ungültige Einstellungen erhalten“. Der Kanal 'CHANNEL_NAME' bleibt inaktiv, bis er ordnungsgemäß konfiguriert ist.
Problem
Die Instanzen der vRealize Log Insight-Agenten werden auf der Seite angezeigt. In Bezug auf die Hostnamen der vRealize Log Insight-Agenten werden auf der Seite „Protokolle durchsuchen“ jedoch keine Protokolle angezeigt. Der Flatfile-Erfassungskanal ist nicht richtig konfiguriert.
Ursache
Eine falsche Konfiguration kann den vRealize Log Insight-Agents daran hindern, Protokolle an den vRealize Log Insight-Server weiterzuleiten.
Lösung
- Definieren Sie einen gültigen Erfassungskanal. Stellen Sie sicher, dass der Flatfile-Erfassungskanal richtig konfiguriert ist. Weitere Informationen hierzu finden Sie unter Konfigurieren von vRealize Log Insight-Agenten.
- Versuchen Sie für den vRealize Log Insight-Windows-Agenten Folgendes.
- Wenn Windows-Kanäle aktiviert sind, zeigen Sie den Inhalt der Protokolldateien des vRealize Log Insight-Windows-Agenten an, die sich im Verzeichnis %ProgramData%\VMware\Log Insight Agent\log befinden. Suchen Sie nach Protokollmeldungen in Bezug auf die Kanalkonfiguration, welche die Ausdrücke Hat den Kanal CHANNEL_NAME abonniert enthalten. Typischerweise verwendete Kanäle sind Application, System und Security.
- Wenn ein Kanal nicht korrekt konfiguriert ist, sehen Sie Protokollmeldungen wie diese: Abonnieren der Ereignisse des Kanals CHANNEL_NAME nicht möglich. Fehlercode: 15007. Der angegebene Kanal wurde nicht gefunden. Überprüfen Sie die Kanalkonfiguration. Möglicherweise sehen Sie eine andere Fehlercodenummer als 15007.
- Wenn ein Flatfile-Erfassungskanal nicht korrekt konfiguriert ist, sehen Sie möglicherweise Meldungen wie Für den Kanal 'CHANNEL_NAME' wurden ungültige Einstellungen erhalten. Der Kanal 'CHANNEL_NAME' bleibt inaktiv, bis er ordnungsgemäß konfiguriert ist
- Versuchen Sie für den vRealize Log Insight-Windows-Agenten und den vRealize Log Insight-Agenten Folgendes.
- Wenn kein Flatfile-Erfassungskanal konfiguriert ist, sehen Sie möglicherweise Meldungen wie Bereich 'filelog' wurde in der Konfiguration nicht gefunden. Der Flat-Dateiprotokoll-Collector bleibt inaktiv, bis er ordnungsgemäß konfiguriert wurde
Die Protokolldateien der vRealize Log Insight Agents befinden sich in den folgenden Verzeichnissen.
- Windows - %ProgramData%\VMware\Log Insight Agent\log
- Linux - /var/log/loginsight-agent/
- Wenn kein Flatfile-Erfassungskanal konfiguriert ist, sehen Sie möglicherweise Meldungen wie Bereich 'filelog' wurde in der Konfiguration nicht gefunden. Der Flat-Dateiprotokoll-Collector bleibt inaktiv, bis er ordnungsgemäß konfiguriert wurde
Nächste Maßnahme
Weitere Informationen über das Konfigurieren der vRealize Log Insight Agents finden Sie unter Konfigurieren des Log Insight Windows Agent und Konfigurieren des Log Insight Linux Agent.