Die Log Insight Agents lehnen ein selbstsigniertes Zertifikat ab.
Problem
Ein vRealize Log Insight-Agent lehnt selbstsignierte Zertifikate ab und kann keine Verbindung mit dem Server herstellen.
Hinweis: Bei Verbindungsproblemen mit dem Agent können Sie detaillierte Protokolle für die Überprüfung generieren, indem Sie die Debug-Stufe für den Agent auf 1 ändern. Weitere Informationen finden Sie unter
Festlegen der Protokolldateiebene in den Log Insight Agents.
Ursache
Die Meldungen im Agent-Protokoll wurden aus bestimmten Gründen in das Protokoll eingetragen.
Meldung | Ursache |
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Selbstsigniertes Zertifikat wird abgelehnt. Der öffentliche Schlüssel stimmt nicht mit dem Schlüssel des vorher gespeicherten Zertifikats überein. |
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Selbstsigniertes Zertifikat wird abgelehnt. Es ist bereits ein Zertifikat einer vertrauenswürdigen Zertifizierungsstelle vorhanden. | Auf dem Agent ist bereits ein Zertifikat einer vertrauenswürdigen Zertifizierungsstelle gespeichert. |
Lösung
- ♦ Überprüfen Sie, ob es sich bei Ihrem Zielhostnamen um eine vertrauenswürdige vRealize Log Insight-Instanz handelt, und löschen Sie das frühere Zertifikat anschließend manuell aus dem Verzeichnis cert des vRealize Log Insight-Agent.
- Log Insight Windows Agent: Navigieren Sie zu C:\ProgramData\VMware\Log Insight Agent\cert.
- Log Insight Linux Agent: Navigieren Sie zu /var/lib/loginsight-agent/cert.
Hinweis: Auf einigen Plattformen können die Pfade der Verzeichnisse mit den vertrauenswürdigen Zertifikaten anders ausfallen. In den Log Insight Agents kann der Pfad zu den vertrauenswürdigen Zertifikaten über den Konfigurationsparameter ssl_ca_path=<fullpath> festgelegt werden. Ersetzen Sie<fullpath>
durch den Pfad zur Paketdatei der vertrauenswürdigen Stammzertifikate. Siehe Konfigurieren der SSL-Parameter für die Log Insight-Agenten