When you start the Horizon FLEX virtual machine, you cannot connect to the Horizon FLEX server because the client version that you are using is incompatible with the server version.

Problem

When you open a Horizon FLEX virtual machine or try to connect to the server, a message appears: You need to upgrade your client or The server is running a newer version than supported by this software. Please download a newer version to resolve this issue.

Cause

The Horizon FLEX server requires that you use a specific Horizon FLEX Client version.

Procedure

Contact your Horizon FLEX administrator to find out the Horizon FLEX Client version to upgrade to.