Upgrading the Tenant App to the latest version fails with a Berkely DB error.
Problem
When you try to upgrade the Tenant App to the latest version, the upgrade fails with the error, 'Failed to install updates (Error while running installation tests)'.
You can view
/opt/vmware/var/log/vami/updatecli.log for the following information:
- Error: rpmdb: BDB0113 Thread/process 2707/139910771108032 failed: BDB1507 Thread died in Berkeley DB library
- Error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
- Error: cannot open Packages index using db5 - (-30973)
- Error: cannot open Packages database in /var/lib/rpm
Cause
This issue is caused when the rpm process accessing Berkeley DB library is interrupted either during the current run or at some other time.
Solution
- Move or remove the lock files mv /var/lib/rpm/__db* /tmp/.
- Rebuild the Berkley DB index
rpm --rebuilddb -vv
. - Perform a YUM clean all.
- Update from vami again.