In a large Site Recovery Manager environment, you might encounter timeout errors when powering on virtual machines on a shared recovery site.

Problem

When you power on virtual machines on a shared recovery site, you see the error message Error:Operation timed out:900 seconds.

Cause

This problem can occur if a single vCenter Server instance manages a large number of virtual machines on the shared recovery site, for example 1000 or more.

Solution

  1. Go to C:\Program Files\VMware\VMware vCenter Site Recovery Manager\config on the Site Recovery Manager Server host machine on the recovery site.
  2. Open vmware-dr.xml in a text editor.
  3. Increase the default RemoteManager timeout value.

    The default timeout value is 900 seconds (15 minutes). Increase the timeout to, for example, 1800 seconds (30 minutes).

    <RemoteManager>
      <DefaultTimeout>1800</DefaultTimeout>
    </RemoteManager>
  4. Set the timeout for reading from the vSphere Web Client.

    Set the timeout to 900 seconds (15 minutes) by adding a line to the <vmacore><http> element.

    <vmacore>
      <http>
        <defaultClientReadTimeoutSeconds>900</defaultClientReadTimeoutSeconds>
      </http>
    </vmacore>
  5. Restart the Site Recovery Manager Server service.

What to do next

If you still experience timeouts after increasing the RemoteManager timeout value, experiment with progressively longer timeout settings. Do not increase the timeout period excessively. Setting the timeout to an unrealistically long period can hide other problems, for example problems related to communication between Site Recovery Manager Server and vCenter Server or other services that Site Recovery Manager requires.