Before you can upgrade Site Recovery Manager, you must perform preparatory tasks on both Site Recovery Manager sites.

Prerequisites

  • Because of update release schedules, upgrading to certain Site Recovery Manager 5.8.x update releases is not supported for all 5.1.x and 5.5.x releases. For information about supported upgrade paths, see Solution Upgrade Path > VMware vCenter Site Recovery Manager in the VMware Product Interoperability Matrixes at http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php? before you upgrade.

    Important:

    Upgrading from Site Recovery Manager 5.0.x to Site Recovery Manager 5.8 is not supported. Upgrade Site Recovery Manager 5.0.x to a Site Recovery Manager 5.5.x release before you upgrade to Site Recovery Manager 5.8. See Upgrading Site Recovery Manager in the Site Recovery Manager 5.5 documentation for information about upgrading from 5.0.x to 5.5.x.

  • If you are using certificate-based authentication, provide the certificate for the remote site to the vSphere Web Client service on each site. See Provide Trusted CA Certificates to vSphere Web Client.

  • To use Site Recovery Manager with vSphere Replication, deploy the appropriate version of vSphere Replication on both of the protected and recovery sites before you upgrade Site Recovery Manager Server. The Site Recovery Manager installer verifies the version of vSphere Replication during installation and stops if it detects an incompatible version. This verification is not performed if you install vSphere Replication after you upgrade Site Recovery Manager Server, which might lead to incompatible versions. Incompatible versions of Site Recovery Manager and vSphere Replication cause the vSphere Web Client to stop working. For information about compatibility between vSphere Replication and Site Recovery Manager versions, see vSphere Replication Requirements in the Compatibility Matrixes for vCenter Site Recovery Manager 5.8 at https://www.vmware.com/support/srm/srm-compat-matrix-5-8.html.

  • If you have existing vSphere Replication appliances on the sites, you must either upgrade them to the correct version or unregister them from both vCenter Server instances before you upgrade Site Recovery Manager. Incompatible versions of Site Recovery Manager and vSphere Replication cause the vSphere Web Client to stop working. See Unregister an Incompatible Version of vSphere Replication.

  • Migration of data from an external database to the embedded database is not supported. For information about how to back up the embedded database, see Back Up and Restore the Embedded vPostgres Database.

  • Important:

    Verify that there are no pending cleanup operations on recovery plans and that there are no configuration issues for the virtual machines that Site Recovery Manager protects.

    • All recovery plans are in the Ready state.

    • The protection status of all of the protection groups is OK.

    • The protection status of all of the individual virtual machines in the protection groups is OK.

    • The recovery status of all of the protection groups is Ready.

  • If you configured advanced settings in the existing installation, take a note of the settings that you configured before upgrading.

  • The local and remote vCenter Server instances must be running when you upgrade Site Recovery Manager.

  • Upgrade all of the vCenter Server components and Site Recovery Manager on one site before you upgrade vCenter Server and Site Recovery Manager on the other site.

  • Download the Site Recovery Manager installation file to a folder on the machines on which to upgrade Site Recovery Manager.

  • Verify that no reboot is pending on the Windows machine on which to install Site Recovery Manager Server. Verify that no other installation is running, including the silent installation of Windows updates. Pending reboots or running installations can cause the installation of Site Recovery Manager Server to fail.

Procedure

  1. Back up the Site Recovery Manager database by using the tools that the database software provides.
  2. Upgrade vCenter Server.

    Site Recovery Manager 5.8.0 requires vCenter Server 5.5 update 2. For information about compatibility between vCenter Server and Site Recovery Manager 5.8 update releases, see vCenter Server Requirements in the Compatibility Matrixes for vCenter Site Recovery Manager 5.8 at https://www.vmware.com/support/srm/srm-compat-matrix-5-8.html.

    Important:

    You must upgrade all components of vCenter Server, including the Inventory Service as well as vCenter Server itself.

  3. Upgrade the vSphere Web Client server.

    Site Recovery Manager 5.8 requires the appropriate version of the vSphere Web Client. Site Recovery Manager 5.8 does not support the vSphere Client for Windows.

  4. Upgrade vSphere Replication.

    Site Recovery Manager 5.8.0 requires vSphere Replication 5.8.0. If you cannot upgrade vSphere Replication, you must unregister the vSphere Replication appliance from vCenter Server.