Reconfiguring Site Recovery Manager fails after you upgrade a vCenter Server 6.5.x or 6.7.x instance with an external Platform Services Controller to an embedded vCenter Server 7.x node.
Problem
When you attempt to reconfigure
Site Recovery Manager after an upgrade of a
vCenter Server 6.5. or 6.7.x with an external
Platform Services Controller to a
vCenter Server with an embedded 7.x node, the operation fails with an error.
ERROR
Operation Failed
A general system error occurred: 22ConfigurationException Failed to configure DR server with the Infrastructure Node services. Reason: Fault cause: lookup.fault.EntryExistsFault
Exit code: 61
Cause
When you upgrade a vCenter Server 6.5.x or 6.7.x instance with an external Platform Services Controller to a vCenter Server 7.x instance with an embedded node the vCenter Single Sign-On site name id changes.
Solution
- Record the serviceId from the
Error 61 message.
- Log in with vCenter Server credentials to https://<vCenter_Server_address>/lookupservice/mob/ on the protected site.
- Navigate to to delete serviceId: <serviceId>.
- Log in to the Site Recovery Manager Appliance Management on the protected site as admin.
- Click Summary, click Reconfigure, and follow the prompts.
- Record the serviceId from the
Error 61 message.
- Log in with vCenter Server credentials to https://<vCenter_Server_address>/lookupservice/mob/ on the recovery site.
- Navigate to to delete serviceId: <serviceId>.
- Log in to the Site Recovery Manager Appliance Management as admin.
- In the Site Recovery Manager Appliance Management Interface, click Services.
- Select the srm-server service, click Stop, then click OK.
- SSH to the upgraded embedded vCenter Server, run the following command and take note of the vCenter Single Sign-On site name.
/usr/lib/vmware-vmafd/bin/vmafd-cli get-site-name --server-name localhost
- SSH to Site Recovery Manager, run the following comment and take node of the db_id.
echo "select * from pds_solutionuser;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
Note: Password is the
password for the embedded vPostgres database that you set during the installation of
Site Recovery Manager.
- Run the following command.
echo "update pds_solutionuser set siteid = 'default-first-site' where db_id =<db_id> ;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
- Log in to the Site Recovery Manager Appliance Management on the recovery site as admin and reconfigure Site Recovery Manager.
- Log in to Site Recovery Manager on the protected site.
- On the Site Recovery home tab, select a site pair, and click View Details.
- Select , and click Reconnect.
- If you encounter an error, restart both Site Recovery Manager instances and vCenter Server instances and repeat the reconnect operation.
Unable to connect to Site Recovery Manager Server at https://<SRM FQDN/IP>:443/drserver/vcdr/vmomi/sdk.
Reason: java.net.SocketTimeoutException: 30,000 milliseconds timeout on connection http-outgoing-431 [ACTIVE]