Ensure you meet the following software requirements for each of your application servers and your database server. You can find the software requirements for the various AirWatch components, such as VMware Enterprise Systems Connector, Tunnel, and SEG, in their applicable guides, available on AirWatch Resources.

Application Server Software Requirements

Ensure that you meet the following software requirements for the application servers:

  • Internet Explorer 9+ installed on all application servers
  • Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, or Windows Server 2016
  • Microsoft SQL Server 2012 Native Client 11.3.6538.0 is required to run the database installer. If you do not want to install Microsoft SQL Server 2012 Native Client 11.3.6538.0 on to your database server, then run the database installer from another AirWatch server or a jump server where Microsoft SQL Server 2012 Native Client 11.3.6538.0 can be installed.
  • 64-bit Java (JRE 1.8) server needed for the server AWCM is installed on
  • 64-bit Java (JRE 1.8) installed on all app servers

  • .NET Framework 4.6.2 required; .NET 4.7 is supported. The installer is packaged with the .NET Framework 4.6.2 installer and will install it if 4.6.2 or 4.7 is not already present.
  • PowerShell version 3.0+ is required if you are deploying the PowerShell MEM-direct model for email. To check your version, open PowerShell and run the command $PSVersionTable. More details on this and other email models can be found in the VMware AirWatch Mobile Email Management Guide, available on AirWatch Resources.

Database Server Software Requirements

  • SQL Server 2012, SQL Server 2014, or SQL Server 2016 with Client Tools (SQL Management Studio, Reporting Services, Integration Services, SQL Server Agent, latest service packs). Ensure the SQL Servers are 64-bit (OS and SQL Server).

    AirWatch does not support Express, Workgroup, or Web editions of SQL Server. These editions do not support all the features used in the AirWatch application. Currently only Standard and Enterprise Editions are supported.

  • Microsoft SQL Server 2012 Native Client 11.3.6538.0 is required to run the database installer. If you do not want to install Microsoft SQL Server 2012 Native Client 11.3.6538.0 on to your database server, then run the database installer from another AirWatch server or a jump server where Microsoft SQL Server 2012 Native Client 11.3.6538.0 can be installed.
  • .NET 4.6.2 is required to run the database installer. If you do not want to install .NET on to your database server, then run the database installer from another AirWatch server or a jump server where .NET can be installed.
  • Ensure the SQL Server Agent Windows service is set to Automatic or Automatic (Delayed) as the Start type for the service. If set to Manual, it has to be manually started before database installation.
  • You must have the access and knowledge required to create, back up, and restore a database.