Before you install or upgrade AppDefense, consider your network configuration and resources. You can install one AppDefense Appliance per vCenter Server.

Note: The scale limit for the virtual machine (VM) with AppDefense installed is 2000 VMs. AppDefense supports up to 200 hosts, with maximum of 50 VMs per host.
Table 1. Required Components
Product/Component Description Supported Version

VMware vCenter Server

Used to manage the ESXi infrastructure. You can install AppDefense plug-in for the Platinum edition. 6.7 U1 and later

The AppDefense plug-in is supported only with 6.7 U1 or later, and in the HTML5 version of the vSphere Client.

VMware vCenter Server

Used to manage the ESXi infrastructure. You can install AppDefense without plug-in from AppDefense Service. 6.5.x
VMware ESXi Hypervisor where the virtual infrastructure is spawned. 6.5 U1 and later
VMware Tools Guest Virtual Machine needs VMware Tools installed. AppDefense Guest Module is bundled with latest VMware Tools.

Recommended is latest 10.3.10 version.

Supported 10.3.2 and later
VMware NSX Data Center for vSphere (optional) To leverage the network virtualization, integrate with NSX and use for remediation actions. 6.3.6 and later (Advance or Enterprise Plus license required)

For details, see VMware Product Interoperability Matrices.

VMware vRealize Automation (optional) Provisioning system to manage a deployment of the application. 7.4 and 7.5

For details, see VMware Product Interoperability Matrices.

Windows Guest Operating System
  • Windows Server 2008 R2 x64
  • Windows Server 2012 x64
  • Windows Server 2012 R2 x64
  • Windows Server 2016 x64
  • Windows Server 2019 x64
Note: Windows guest operating system with the Virtualization-based security (VBS) feature enabled is NOT supported.
Linux Guest Operating System
  • CentOS - 7.1, 7.2, 7.3, 7.4, 7.6 (x86_64)
  • RHEL - 7.0, 7.3, 7.4, 7.6 (x86_64)
  • Ubuntu - 14.04, 16.04 (x86_64)
  • SUSE - 12.2, 12.3 (x86_64)

RHEL 7.6 and CentOS 7.6 are supported only from Guest Module version 2.0.4.0 or later.

Supported Browsers Internet Explorer 11 or Microsoft Edge, Google Chrome