You must verify the following components on the virtual machine before the actual installation. The AppDefense solution works with Guest Introspection for NSX (VMware open-source product) to provide a network attestation service.

Ensure that the guest virtual machine (VM) has:

  1. ESXi 6.5 U1 or later is installed.

  2. A supported version of Linux is installed.

    See System Requirements For AppDefense for the list of supported Linux distributions and versions.

  3. iptables package of 1.4.11 version or later is installed.
  4. Verify glib 2 is installed on the Linux VM.

There are few known limitations for AppDefense to work with Linux VM. For details, refer to the Known Limitation With Linux VMs.