Before you install or upgrade AppDefense, consider your network configuration and resources. You can install one AppDefense Appliance per vCenter Server.

Note: The scale limit for the virtual machine (VM) with AppDefense installed is 3000 VMs. AppDefense supports up to 250 hosts, with maximum of 50 VMs per host. This limit is per AppDefense Appliance which is per vCenter Server.
Table 1. Required Components
Product/Component Description Supported Version

VMware vCenter Server

Used to manage the ESXi infrastructure. You can install AppDefense plug-in for the Platinum edition. 6.7 U1 and later

The AppDefense plug-in is supported only with 6.7 U1 or later, and in the HTML5 version of the vSphere Client.

VMware vCenter Server

Used to manage the ESXi infrastructure. You can install AppDefense without plug-in from AppDefense Service. 6.5.x
VMware ESXi Hypervisor where the virtual infrastructure is spawned. 6.5 U1 and later

AppDefense release 2.3.2 or later is supported only with 6.5 U2 and later.

VMware Tools Guest Virtual Machine needs VMware Tools installed. AppDefense Guest Module is bundled with latest VMware Tools.

Recommended is latest 11.1.0 version.

Supported 10.3.2 and later.
VMware NSX Data Center for vSphere (optional) To leverage the network virtualization, integrate with NSX Data Center and use for remediation actions. 6.3.6 and later (Advance or Enterprise Plus license required)

For details, see VMware Product Interoperability Matrices.

VMware NSX-T Data Center (optional) To leverage the network virtualization, integrate with NSX-T Data Center and use for remediation actions. 2.4 and later (Professional or above license required)

For details, see VMware Product Interoperability Matrices.

VMware vRealize Automation (optional) Provisioning system to manage a deployment of the application. 7.4, 7.5, and 7.6

For details, see VMware Product Interoperability Matrices.

Windows Guest Operating System
  • Windows Server 2008 R2 SP1x64
  • Windows Server 2012 x64
  • Windows Server 2012 R2 x64
  • Windows Server 2016 x64
  • Windows Server 2019 x64

For Windows Server 2019, the supported version for VMware Tools is 10.3.10 or later.

Note: Windows guest operating system with the Virtualization-based Security (VBS) feature enabled is supported from AppDefense 2.3.2 or later. For details, refer to the Microsoft Virtualization-Based Security (VBS) Support topic.
Linux Guest Operating System
  • CentOS - 7.1, 7.2, 7.3, 7.4, 7.6 (x86_64)
  • RHEL - 7.0, 7.2, 7.3, 7.4, 7.6, 7.7, 7.8, 8.0, 8.2 (x86_64)
  • Ubuntu - 14.04, 16.04 (x86_64)
  • SUSE - 12.2, 12.3 (x86_64)

RHEL 7.8, 8.0, 8.2 is supported only from Guest Module version 2.3.2 or later.

RHEL 7.7 is supported only from Guest Module version 2.3.0.0 or later.

RHEL 7.6 and CentOS 7.6 are supported only from Guest Module version 2.0.4.0 or later.

Supported Browsers Internet Explorer 11 or Microsoft Edge, Google Chrome.
Important: AppDefense does not work with virtual machines that have Fault Tolerance enabled. This limitation applies to both Linux and Windows guest virtual machines.