The deployments and resources are not visible in ServiceNow.
Problem
Even after running the scheduled job, deployments and resources are not displayed in ServiceNow.
Cause
This problem occurs as some fields in the CMDB_ci_appl table have mandatory conditions.
Solution
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Right-click on the header bar > configure and open the
CMDB_ci_appltable. -
Check if the following mandatory field is set to
true:-
Locate the mandatory fields that are set to
true, make them non-mandatory, and save them. -
Check if you are allowed to make any changes in the
CMDB_ci_appltable. If not, then you need to make changes in thex_vmw_cloudservice_deploymentstable.
-
-
To make changes, perform the following:
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In the
x_vmw_cloudservice_deploymentstable, locate the mandatory field that is set totrue. -
Navigate to Dictionary Override > Create new record in the selected
x_vmw_cloudservice_deploymentstable. -
Select the Override mandatory check box and click Submit.
Note:If there is a mandatory condition in the
x_vmw_cloudservice_deploymentscolumn that does not have any condition set, then update it to mandatoryfalseor create a dictionary override.
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