Some of the metrics are depends on Helpdesk APIs.

Problem

Missing Helpdesk Metrics due to Helpdesk API

All protocol metrics, historical performance and application metrics on Horizon sessions will be missing.

Cause

  1. Flag "Enable Historical Performance Metric Collection For RDS"set to False, disables Overall CPU, Overall Memory & Disk IOPS metrics and turns off Helpdesk API calls for historical performance metrics.

  2. Flag "Enable Protocol Performance Metric Collection" set to False,disables Frame Rate, Latency, Packet Loss Receive, Packet Loss Transmit, Bandwidth Transmit Utilization metrics and turns off Helpdesk API calls for protocol metrics.

  3. Flag "Enable Application Metric Collection" set to False, disables CPU, disk utilization metrics and turns off Helpdesk API calls for Horizon application sessions.

  4. Helpdesk API plugin is not enabled in the Horizon agent, the adapter won't be able to collect metrics. As a symptom you will be observing "ErrorCode=1001 - Unable to forward message to the AgentHelpDesk queue: NoQueueHandler" error message in the logs.

Solution

  1. Enable Helpdesk plugin in the Horizon agent and ensure the Horizon Helpdesk licenses are available.

  2. Enable the corresponding flags in the Advanced settings of adpater