An incorrect configuration can prevent the VMware Aria Operations for Logs agents from forwarding logs to the VMware Aria Operations for Logs server. If a flat file collection channel is not configured correctly, you may see messages such as “Invalid settings were obtained for channel 'CHANNEL_NAME'. Channel 'CHANNEL_NAME' will stay dormant until properly configured.”

Problem

The VMware Aria Operations for Logs agents instances appears on the Management > Agents page but no logs appear in the Explore Logs page from the VMware Aria Operations for Logs agents host names. The flat file collection channel is not configured correctly.

Cause

Incorrect configuration can prevent the VMware Aria Operations for Logs agents from forwarding logs to the VMware Aria Operations for Logs server.

Solution

  • Define a valid collection channel. Verify whether or not the flat file collection channel is configured correctly. See Configuring VMware Aria Operations for Logs Agents.
  • For the VMware Aria Operations for Logs Windows agent, try the following.
    • If Windows channels are enabled, view the contents of the VMware Aria Operations for Logs Windows agent log files located at %ProgramData%\VMware\Log Insight Agent\log. Look for log messages related to channel configuration that contain the phrases Subscribed to channel CHANNEL_NAME. Typically-used channels are Application, System, and Security.
    • If a channel is not configured correctly, you might see log messages similar to Could not subscribe to channel CHANNEL_NAME events. Error Code: 15007. The specified channel could not be found. Check channel configuration. You might see an error code number other than 15007.
    • If a flat file collection channel is not configured correctly, you might see messages like Invalid settings were obtained for channel 'CHANNEL_NAME'. Channel 'CHANNEL_NAME' will stay dormant until properly configured
  • For both VMware Aria Operations for Logs Windows agent and VMware Aria Operations for Logs Linux agent, try the following.
    • If no flat file collection channel is configured, you might see messages similar to Cannot find section 'filelog' in the configuration. The flat file log collector will stay dormant until properly configured
      The contents of the VMware Aria Operations for Logs agents log files are located in the following directories.
      • Windows - %ProgramData%\VMware\Log Insight Agent\log
      • Linux - /var/log/loginsight-agent/

What to do next

For more information about configuring the VMware Aria Operations for Logs agents see Configure the VMware Aria Operations for Logs Windows Agent and Configure the VMware Aria Operations for Logs Linux Agent.