If the time settings between cloud proxy and VMware Aria Operations are not synchronized, you might face agent installation and metric collection issues. Eventually, you might not see any metrics in the VMware Aria Operations dashboards.

Problem

You might notice the following issues in VMware Aria Operations:
  • You cannot install an agent in the Windows and Linux target VMs.

Cause

Time synchronization is a prerequisite of the TLS/SSO communication between client and server.

If the VMware Aria Operations and cloud proxy are not time synchronized, the test connection fails while configuring cloud proxy in VMware Aria Operations.

If the Windows and Linux target VMs are not time synchronized with VMware Aria Operations, communication between cloud proxy and agents will break after installing the agents. Hence monitored metrics are not sent to VMware Aria Operations. Alternatively, stop and restart the agent to resolve this issue.

Solution

  1. Check the VMware Aria Operations support bundle in the following path: COLLECTOR/adapters/APPOSUCPAdapter/ for errors.
  2. Check the cloud proxy support bundle, ucpapi.log, for errors.
  3. Ensure time synchronization between cloud proxy, VMware Aria Operations and the Windows and Linux target VMs.
  4. To start and restart the agent, see Additional Operations from the Manage Telegraf Agents Page.