App Launchpad requires external components and supports specific versions that you must deploy and configure.

Table 1. Versions of Required External Components
Required Component Supported Versions
VMware Cloud Director
  • 10.3
  • 10.2
  • 10.1
  • 10
AMQP Broker Depends on the AMQP Broker that your version of VMware Cloud Director supports. For information, see the VMware Cloud Director Release Notes for the version of VMware Cloud Director that you run.

If you use VMware Cloud Director 10.1 or 10, an AMQP broker is required.

If you use VMware Cloud Director 10.2, configuring an AMQP broker is not required.

System Requirements

App Launchpad is available for an installation on CentOS Linux 7 and 8 distribution versions.

Hardware Requirements

The following table lists the hardware requirements for minimal and optimal deployments of App Launchpad.
Deployment Type Hardware Requirements
Minimal
  • 2 Core CPU
  • 4 GB RAM
  • 8 GB Free Disk Space
Optimal
  • 4 Core CPU
  • 16 GB RAM
  • 120 GB Free Disk Space