If VMware Cloud Director cells restrict outbound access to AWS S3, subscribing to the Bitnami applications catalog in VMware Marketplace fails with the vApp template synchronization tasks timing out.

Problem

Attempting to import Bitnami applications from VMware Marketplace times out at 1% of the task completed.

Also, VMware Cloud Director logs report that the hostname *.s3.us-west-2.amazonws.com is not reachable.

To verify that outbound access is restricted, run the following command from the VMware Cloud Director cell machine:
curl -i -k -v https://s3.us-west-2.amazonaws.com
If outbound access is restricted, the system returns a Status 307 message.

Cause

The Bitnami applications are stored in AWS S3. If VMware Cloud Director cannot access the Bitnami catalogs, importing and synchronizing applications is not possible.

Solution

To work around such issues, allow outbound access to AWS S3 from the VMware Cloud Director cell. If VMware Cloud Director cells allow outbound access through an HTTP proxy, make sure that the proxy host is configured on the cell machine.