Cloud sites management includes establishing and re-establishing trust between sites. After you initiate pairing from the local site and complete the pairing from the remote site, VMware Cloud Director Availability establishes a trust between the two cloud sites. Re-establish the trust after upgrading VMware Cloud Director Availability, after replacing the Cloud Service certificate, or after registering additional Replicator Service instances.

VMware Cloud Director Availability to VMware Cloud Director Availability Interoperability

You can pair sites that have different VMware Cloud Director Availability versions deployed, up to two versions back. For example, you can pair a cloud site where version 4.1 is deployed with an on-premises site where version 3.5 is deployed. You can also pair the cloud site with another cloud site where version 3.5 is deployed. This scenario can occur when upgrading the sites one at a time or to migrate workloads from an earlier vSphere and VMware Cloud Director versions to a site with current vSphere and VMware Cloud Director versions.

Note: When pairing sites with different VMware Cloud Director Availability versions, only the functionality of the earlier version is supported. For example, only the functionality of version 3.5 is supported when pairing a site where version 3.5 is deployed with a site where version 4.1 is deployed.

Before pairing VMware Cloud Director Availability sites, verify the interoperability of the versions of VMware Cloud Director Availability between the source site and the destination site in the following tables:

Table 1. Pairing Interoperability Between the Version of VMware Cloud Director Availability On-Premises Appliance the Version of the VMware Cloud Director Availability in the Cloud Site

VMware Cloud Director Availability On-Premises Appliance

Cloud Site

3.0

Cloud Site

3.5

Cloud Site

4.0

Cloud Site 4.1
3.0 Supported Supported Supported Unsupported
3.5 Supported Supported Supported Supported
4.0 Supported Supported Supported Supported
4.1 Unsupported Supported Supported Supported
Note: Do not pair sites with more than two major versions apart. For example, pairing version 4.1 with version 3.5 is supported, but pairing version 4.1 with version 3.0 is not supported.
Table 2. Pairing Interoperability Between the Version of VMware Cloud Director Availability in the Source Cloud Site and the Version of the VMware Cloud Director Availability in the Destination Cloud Site
Source Cloud Site

VMware Cloud Director Availability

Destination Cloud Site

3.0

Destination Cloud Site

3.5

Destination Cloud Site

4.0

Destination Cloud Site 4.1
3.0 Supported Supported Supported Unsupported
3.5 Supported Supported Supported Supported
4.0 Supported Supported Supported Supported
4.1 Unsupported Supported Supported Supported
Important: When pairing sites, ensure that the latest maintenance release for the VMware Cloud Director Availability version is deployed in each site. For example:
  • For version 3.0, the site must be running version 3.0.5 or if later is available.
  • For version 3.5, the site must be running version 3.5.2 or if later is available.
  • For version 4.0, the site must be running version 4.0.1.1 or if later is available.

Migration from Earlier VMware Cloud Director Availability Versions

By pairing an earlier and later VMware Cloud Director Availability versions, you can migrate workloads from source sites where the latest VMware Cloud Director Availability version does not support either the version of vCenter Server or VMware Cloud Director.

VMware Cloud Director Availability is fully capable of migrating workloads running on earlier vSphere and VMware Cloud Director versions that are near or are already EOS. If there is a VMware Cloud Director Availability version compatible with the vSphere and the VMware Cloud Director versions in the source site, you can pair it to VMware Cloud Director Availability 4.0 deployed in a cloud site with current vSphere and VMware Cloud Director versions. For example, see the following table:

Table 3. VMware Cloud Director Availability Migration Interoperability with Paired Sites
Source Site

VMware Cloud Director Availability

Destination Site

VMware Cloud Director Availability

On-premises site A, deployed version 3.5 with vSphere 5.5 or later. Cloud site C, VMware Cloud Director Availability 4.1 with a supported VMware Cloud Director version*.
Cloud site B, deployed version 3.5 with vCloud Director 9.0 or 9.1.
Cloud site Y, deployed version 3.0 with vCloud Director 8.2, 9.0 or 9.1. Cloud site Z, VMware Cloud Director Availability 4.0 with a supported VMware Cloud Director version*.
  • In an on-premises site with vSphere 5.5, deploy an on-premises appliance version 3.5 and pair it to VMware Cloud Director Availability 4.1 deployed in a cloud site with a supported VMware Cloud Director version*. You can then migrate all virtual machines to the later cloud site.
  • In a cloud site with vCloud Director 9.0, deploy version 3.0 and pair it to VMware Cloud Director Availability 4.0 deployed in a cloud site with a supported VMware Cloud Director version*. You can then migrate all vApps to the later VMware Cloud Director site.

VMware Cloud Director Availability Interoperability Matrices

* Before deploying VMware Cloud Director Availability in the cloud site, verify the supported versions of VMware Cloud Director and NSX by following the link bellow.

Before deploying VMware Cloud Director Availability On-Premises Appliance, verify the supported versions of vCenter Server, ESXi, and NSX by following the link bellow.

For information about the VMware Cloud Director Availability interoperability with other VMware products, see VMware Product Interoperability Matrices.