You are unable to access the VMware Cloud Director Availability Tenant Portal through the VMware Cloud Director Service Provider Admin Portal and the VMware Cloud Director Tenant Portal.

Problem

  • The Availability menu option is not available in the VMware Cloud Director Service Provider Admin Portal and the VMware Cloud Director Tenant Portal, or clicking it does not open the VMware Cloud Director Availability Tenant Portal.
  • In the VMware Cloud Director Availability logs, you see an error message such as Unable to register vCAV plugin in vCD.

Cause

Connectivity problems during the initial configuration of VMware Cloud Director Availability might prevent the VMware Cloud Director Availability plug-in from registering with VMware Cloud Director.

Solution

  1. Log in to the VMware Cloud Director Availability management interface.
    1. In a web browser, go to https://Appliance-IP-address/ui/admin.
    2. Select SSO login or Appliance login, and enter the single sign-on or the root user credentials.
    3. Click Login.
  2. Re-register the VMware Cloud Director Availability plug-in with VMware Cloud Director.
    1. In the left pane under Configuration, click Settings.
    2. Under Service endpoints, next to the VMware Cloud Director address click Edit.
    3. In the VMware Cloud Director Details window, configure the VMware Cloud Director endpoint.
      Option Description
      VMware Cloud Director Endpoint address Enter the endpoint address as https://VMware-Cloud-Director-IP-Address:443/api.

      VMware Cloud Director Username

      Enter the system administrator user name, that is used for all administrative operations. For example, administrator@system, where system is the name of the system organization of VMware Cloud Director.

      VMware Cloud Director Password

      Enter the system administrator password.
    4. Click Apply.
    5. To complete the VMware Cloud Director configuration, verify the thumbprint and accept the VMware Cloud Director SSL certificate.
  3. On the System Monitoring tab, click Restart Service and confirm the operation.